# CVE-2020-25701: Privilage Escalation in moodle

> Attackers can gain unauthorized course access by exploiting a logic error in the upload tool that erroneously enables disabled enrollment methods.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-moodle-2020-25701, GHSA-c9hq-g4q8-w893, UBUNTU-CVE-2020-25701

## What is CVE-2020-25701?

CVE-2020-25701 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2020-25701?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.15 |
| `moodle/moodle` | Packagist | From 3.5 | 3.5.15 |
| `moodle/moodle` | Packagist | From 3.7.0 | 3.7.9 |
| `moodle/moodle` | Packagist | From 3.7.0 | 3.7.9 |
| `moodle/moodle` | Packagist | From 3.8.0 | 3.8.6 |
| `moodle/moodle` | Packagist | From 3.8.0 | 3.8.6 |
| `moodle/moodle` | Packagist | From 3.9.0 | 3.9.3 |
| `moodle/moodle` | Packagist | From 3.9.0 | 3.9.3 |
| `moodle` | Bitnami | From 3.5.0 | 3.5.15, 3.7.9, 3.8.6, 3.9.3 |

Products: Fedoraproject Fedora, Moodle Moodle.

## How do I fix CVE-2020-25701?

Upgrade moodle/moodle to a fixed version for your release line: 3.5.15, 3.7.9, 3.8.6 or 3.9.3.

## Is CVE-2020-25701 being exploited?

There is no known exploitation of CVE-2020-25701 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25701 and fix it if it is affected.

What it is: CVE-2020-25701 is a medium-severity vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25701 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.15
- moodle/moodle (Packagist): affected from 3.5; fixed in 3.5.15
- moodle/moodle (Packagist): affected from 3.7.0; fixed in 3.7.9
- moodle/moodle (Packagist): affected from 3.7.0; fixed in 3.7.9
- moodle/moodle (Packagist): affected from 3.8.0; fixed in 3.8.6
- moodle/moodle (Packagist): affected from 3.8.0; fixed in 3.8.6
- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.3
- moodle/moodle (Packagist): affected from 3.9.0; fixed in 3.9.3
- moodle (Bitnami): affected from 3.5.0; fixed in 3.5.15, 3.7.9, 3.8.6, 3.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25701/ (Markdown: https://insights.sbomify.com/CVE-2020-25701/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25701
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25701
- OSV: https://osv.dev/vulnerability/CVE-2020-25701

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25701/
Summaries are generated and may contain mistakes; the official description above is the record.
