CVE-2020-25702 Cross-site Scripting (XSS) in moodle
Attackers can inject JavaScript via content bank item renaming, potentially leading to session hijacking or malicious actions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-25702?
CVE-2020-25702 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Moodle, it was possible to include JavaScript when re-naming content bank items. Versions affected: 3.9 to 3.9.2. This is fixed in moodle 3.9.3 and 3.10.
Weakness: CWE-79
Which versions are affected by CVE-2020-25702?
3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.9.0 | 3.9.3 |
moodle/moodle Packagist | From 3.9.0 | 3.9.3 |
moodle Bitnami | From 3.9.0 | 3.9.3 |
Products include Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2020-25702?
Upgrade moodle/moodle to 3.9.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-25702 being exploited?
There is no known exploitation of CVE-2020-25702 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-moodle-2020-25702, GHSA-pgcp-m69h-p2gr, UBUNTU-CVE-2020-25702.