# CVE-2020-25710: Denial of service in openldap

> An attacker can cause a denial of service in OpenLDAP by sending a malicious packet that triggers a failed assertion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2021
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2020-25710, BIT-openldap-2020-25710, CLEANSTART-2026-FJ95448, DEBIAN-CVE-2020-25710, GHSA-8wg3-gqcw-9fq9, JLSEC-2026-162, OESA-2021-1244, UBUNTU-CVE-2020-25710

## What is CVE-2020-25710?

CVE-2020-25710 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in OpenLDAP in versions before 2.4.56. This flaw allows an attacker who sends a malicious packet processed by OpenLDAP to force a failed assertion in csnNormalize23(). The highest threat from this vulnerability is to system availability.

Weakness: CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2020-25710?

1 open source package ship an affected version, including openldap. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openldap` | Bitnami | All versions | 2.4.56 |

Products: Debian Debian Linux, Fedoraproject Fedora, Openldap Openldap, Redhat Enterprise Linux, Redhat Jboss Core Services, Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Web Server.

## How do I fix CVE-2020-25710?

Upgrade openldap to 2.4.56 or later.

## Is CVE-2020-25710 being exploited?

There is no known exploitation of CVE-2020-25710 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25710 and fix it if it is affected.

What it is: CVE-2020-25710 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 28 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25710 in the wild and no public exploit code.

Affected packages and fixed versions:
- openldap (Bitnami): affected all versions; fixed in 2.4.56

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25710/ (Markdown: https://insights.sbomify.com/CVE-2020-25710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25710
- OSV: https://osv.dev/vulnerability/CVE-2020-25710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25710/
Summaries are generated and may contain mistakes; the official description above is the record.
