{"answers":{"affected":"2 open source packages ship an affected version, including gon. It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-25739 in the wild and no public exploit code.","fix":"Upgrade gon to 6.4.0 or later.","what":"CVE-2020-25739 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-25739 and fix it if it is affected.\n\nWhat it is: CVE-2020-25739 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-25739 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gon (RubyGems): affected all versions; fixed in 6.4.0\n- gon (RubyGems): affected all versions; fixed in 6.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-25739/ (Markdown: https://insights.sbomify.com/CVE-2020-25739/index.md)","id":"CVE-2020-25739","markdown":"https://insights.sbomify.com/CVE-2020-25739/index.md","name":"CVE-2020-25739","record":{"aliases":["DEBIAN-CVE-2020-25739","DLA-2380-1","GHSA-78vq-9j56-wrfr","UBUNTU-CVE-2020-25739","USN-4560-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby gon gem","requires_auth":"none","summary":"The gon gem for Ruby fails to escape fields by default, allowing attackers to inject malicious scripts via XSS.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"gon","vendor":"gon_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in the gon gem before gon-6.4.0 for Ruby. MultiJson does not honor the escape_mode parameter to escape fields as an XSS protection mechanism. To mitigate, json_dumper.rb in gon now does escaping for XSS by default without relying on MultiJson.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Gon gem lack of escaping certain input when outputting as JSON","id":"CVE-2020-25739","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux"],"type":"xss","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Null dereference in n/a","id":"CVE-2020-25741"},"packages":[{"ecosystem":"RubyGems","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"gon","purl":null,"source":"GHSA-78vq-9j56-wrfr"},{"ecosystem":"RubyGems","fixed":["6.4.0"],"introduced":["0"],"last_affected":[],"package":"gon","purl":"pkg:gem/gon","source":"GHSA-78vq-9j56-wrfr"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2020-25738"},"products":["n/a"],"published":"2020-09-23","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"The gon gem for Ruby fails to escape fields by default, allowing attackers to inject malicious scripts via XSS.","url":"https://insights.sbomify.com/CVE-2020-25739/"}