# CVE-2020-25739: Gon gem lack of escaping certain input when outputting as JSON

> The gon gem for Ruby fails to escape fields by default, allowing attackers to inject malicious scripts via XSS.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-25739, DLA-2380-1, GHSA-78vq-9j56-wrfr, UBUNTU-CVE-2020-25739, USN-4560-1

## What is CVE-2020-25739?

CVE-2020-25739 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in the gon gem before gon-6.4.0 for Ruby. MultiJson does not honor the escape_mode parameter to escape fields as an XSS protection mechanism. To mitigate, json_dumper.rb in gon now does escaping for XSS by default without relying on MultiJson.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-25739?

2 open source packages ship an affected version, including gon. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gon` | RubyGems | All versions | 6.4.0 |
| `gon` | RubyGems | All versions | 6.4.0 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Gon Project Gon.

## How do I fix CVE-2020-25739?

Upgrade gon to 6.4.0 or later.

## Is CVE-2020-25739 being exploited?

There is no known exploitation of CVE-2020-25739 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25739 and fix it if it is affected.

What it is: CVE-2020-25739 is a medium-severity cross-site scripting vulnerability in Canonical Ubuntu Linux, published on 23 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-25739 in the wild and no public exploit code.

Affected packages and fixed versions:
- gon (RubyGems): affected all versions; fixed in 6.4.0
- gon (RubyGems): affected all versions; fixed in 6.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25739/ (Markdown: https://insights.sbomify.com/CVE-2020-25739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25739
- OSV: https://osv.dev/vulnerability/CVE-2020-25739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25739/
Summaries are generated and may contain mistakes; the official description above is the record.
