CVE-2020-2574 Denial of service in MySQL Server
An unauthenticated attacker can cause a complete denial of service in the MySQL Client via network access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-2574?
CVE-2020-2574 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 15 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the MySQL Client product of Oracle MySQL (component: C API). Supported versions that are affected are 5.6.46 and prior, 5.7.28 and prior and 8.0.18 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise MySQL Client. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Client. CVSS 3.0 Base Score 5.9 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H).
Which versions are affected by CVE-2020-2574?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 5.5.0 | 5.5.67, 10.1.44, 10.2.31, 10.3.22, 10.4.12 |
mariadb-min Bitnami | From 5.5.0 | 5.5.67, 10.1.44, 10.2.31, 10.3.22, 10.4.12 |
mysql-client Bitnami | From 5.5.0 | 5.5.67, 10.1.44, 10.2.31, 10.3.22, 10.4.12 |
Linux distribution packages (8)
mariadb-100 SUSE:Linux Enterprise Server 12 SP4 | All versions | 10.0.40.3-2.15.1 |
mariadb-100 SUSE:Linux Enterprise Server 12 SP5 | All versions | 10.0.40.3-2.15.1 |
mariadb-100 SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 10.0.40.3-2.15.1 |
mariadb-100 SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 10.0.40.3-2.15.1 |
mariadb-100 SUSE:Linux Enterprise Software Development Kit 12 SP4 | All versions | 10.0.40.3-2.15.1 |
mariadb-100 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 10.0.40.3-2.15.1 |
mariadb-100 SUSE:Linux Enterprise Workstation Extension 12 SP4 | All versions | 10.0.40.3-2.15.1 |
mariadb-100 SUSE:Linux Enterprise Workstation Extension 12 SP5 | All versions | 10.0.40.3-2.15.1 |
Products include Canonical Ubuntu Linux, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter and 2 more.
How do I fix CVE-2020-2574?
Upgrade mariadb to a fixed version for your release line: 5.5.67, 10.1.44, 10.2.31 or 10.3.22.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-2574 being exploited?
There is no known exploitation of CVE-2020-2574 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2020-2574, BIT-mariadb-2020-2574, BIT-mariadb-min-2020-2574, BIT-mysql-client-2020-2574, GHSA-33hv-cjr4-37wm, MGASA-2020-0072 and 3 more.