# CVE-2020-25768: Contao Insert tag injection in forms

> Attackers can inject malicious insert tags in front-end forms, leading to script execution or data exposure when pages are rendered.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f7wm-x4gw-6m23

## What is CVE-2020-25768?

CVE-2020-25768 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contao before 4.4.52, 4.9.x before 4.9.6, and 4.10.x before 4.10.1 have Improper Input Validation. It is possible to inject insert tags in front end forms which will be replaced when the page is rendered.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-25768?

12 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.52 |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.52 |
| `contao/contao` | Packagist | From 4.10.0 | 4.10.1 |
| `contao/contao` | Packagist | From 4.10.0 | 4.10.1 |
| `contao/contao` | Packagist | From 4.5.0 | 4.9.6 |
| `contao/contao` | Packagist | From 4.5.0 | 4.9.6 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.52 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.52 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.10.1 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.10.1 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.9.6 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.9.6 |

Products: Contao Contao.

## How do I fix CVE-2020-25768?

Upgrade contao/contao to a fixed version for your release line: 4.4.52, 4.10.1 or 4.9.6.

## Is CVE-2020-25768 being exploited?

There is no known exploitation of CVE-2020-25768 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25768 and fix it if it is affected.

What it is: CVE-2020-25768 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-25768 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.52
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.52
- contao/contao (Packagist): affected from 4.10.0; fixed in 4.10.1
- contao/contao (Packagist): affected from 4.10.0; fixed in 4.10.1
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.9.6
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.9.6
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.52
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.52
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.10.1
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.10.1
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.9.6
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25768/ (Markdown: https://insights.sbomify.com/CVE-2020-25768/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25768
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25768
- OSV: https://osv.dev/vulnerability/CVE-2020-25768

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25768/
Summaries are generated and may contain mistakes; the official description above is the record.
