CVE-2020-25802 Authenticated attackers with developer privileges in Crafter Studio may execute OS commands via Groovy scripting.
Authenticated developers can execute arbitrary OS commands via Groovy scripting in Crafter Studio, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-25802?
CVE-2020-25802 is a medium-severity code injection vulnerability in Crafter CMS, published on 6 Oct 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Improper Control of Dynamically-Managed Code Resources vulnerability in Crafter Studio of Crafter CMS allows authenticated developers to execute OS commands via Groovy scripting. This issue affects: Crafter Software Crafter CMS 3.0 versions prior to 3.0.27; 3.1 versions prior to 3.1.7.
Weakness: CWE-913
Which versions are affected by CVE-2020-25802?
4 open source packages ship an affected version, including org.craftercms:crafter-studio. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.craftercms:crafter-studio Maven | From 3.0 | 3.0.27 |
org.craftercms:crafter-studio Maven | From 3.0 | 3.0.27 |
org.craftercms:crafter-studio Maven | From 3.1 | 3.1.7 |
org.craftercms:crafter-studio Maven | From 3.1 | 3.1.7 |
Products include Craftercms Studio.
How do I fix CVE-2020-25802?
Upgrade org.craftercms:crafter-studio to a fixed version for your release line: 3.0.27 or 3.1.7.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2020-25802 being exploited?
There is no known exploitation of CVE-2020-25802 in the wild and no public exploit code.
Other vulnerabilities in Crafter CMS
Sources
Also known as GHSA-wq3v-3grq-6f86.