CVE-2020-25812 MediaWiki Cross-site Scripting (XSS) vulnerability
An attacker can execute arbitrary scripts in MediaWiki if specific interface messages are modified to include raw HTML.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-25812?
CVE-2020-25812 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 27 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki 1.34.x before 1.34.4. On Special:Contributions, the NS filter uses unescaped messages as keys in the option key for an HTMLForm specifier. This is vulnerable to a mild XSS if one of those messages is changed to include raw HTML.
Weakness: CWE-79
Which versions are affected by CVE-2020-25812?
5 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.34.0 | 1.34.3 |
mediawiki/core Packagist | From 1.34.0 | 1.34.3 |
mediawiki/core Packagist | From 1.35.0-rc.0 | 1.35.0 |
mediawiki/core Packagist | From 1.35.0-rc.0 | 1.35.0 |
mediawiki Bitnami | From 1.34.0 | 1.34.4 |
Products include Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2020-25812?
Upgrade mediawiki/core to a fixed version for your release line: 1.34.3 or 1.35.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-25812 being exploited?
There is no known exploitation of CVE-2020-25812 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-mediawiki-2020-25812, DEBIAN-CVE-2020-25812, GHSA-rj9p-8jxj-2ch4, UBUNTU-CVE-2020-25812.