# CVE-2020-25812: MediaWiki Cross-site Scripting (XSS) vulnerability

> An attacker can execute arbitrary scripts in MediaWiki if specific interface messages are modified to include raw HTML.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2020-25812, DEBIAN-CVE-2020-25812, GHSA-rj9p-8jxj-2ch4, UBUNTU-CVE-2020-25812

## What is CVE-2020-25812?

CVE-2020-25812 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 27 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in MediaWiki 1.34.x before 1.34.4. On Special:Contributions, the NS filter uses unescaped messages as keys in the option key for an HTMLForm specifier. This is vulnerable to a mild XSS if one of those messages is changed to include raw HTML.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-25812?

5 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | From 1.34.0 | 1.34.3 |
| `mediawiki/core` | Packagist | From 1.34.0 | 1.34.3 |
| `mediawiki/core` | Packagist | From 1.35.0-rc.0 | 1.35.0 |
| `mediawiki/core` | Packagist | From 1.35.0-rc.0 | 1.35.0 |
| `mediawiki` | Bitnami | From 1.34.0 | 1.34.4 |

Products: Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2020-25812?

Upgrade mediawiki/core to a fixed version for your release line: 1.34.3 or 1.35.0.

## Is CVE-2020-25812 being exploited?

There is no known exploitation of CVE-2020-25812 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25812 and fix it if it is affected.

What it is: CVE-2020-25812 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 27 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-25812 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected from 1.34.0; fixed in 1.34.3
- mediawiki/core (Packagist): affected from 1.34.0; fixed in 1.34.3
- mediawiki/core (Packagist): affected from 1.35.0-rc.0; fixed in 1.35.0
- mediawiki/core (Packagist): affected from 1.35.0-rc.0; fixed in 1.35.0
- mediawiki (Bitnami): affected from 1.34.0; fixed in 1.34.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25812/ (Markdown: https://insights.sbomify.com/CVE-2020-25812/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25812
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25812
- OSV: https://osv.dev/vulnerability/CVE-2020-25812

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25812/
Summaries are generated and may contain mistakes; the official description above is the record.
