{"answers":{"affected":"7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-25814 in the wild and no public exploit code.","fix":"Upgrade mediawiki/core to a fixed version for your release line: 1.31.9, 1.34.3 or 1.35.0.","what":"CVE-2020-25814 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 27 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-25814 and fix it if it is affected.\n\nWhat it is: CVE-2020-25814 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 27 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-25814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.9\n- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.9\n- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.34.3\n- mediawiki/core (Packagist): affected from 1.32.0; fixed in 1.34.3\n- mediawiki/core (Packagist): affected from 1.35.0-rc.0; fixed in 1.35.0\n- mediawiki/core (Packagist): affected from 1.35.0-rc.0; fixed in 1.35.0\n- mediawiki (Bitnami): affected all versions; fixed in 1.31.10, 1.34.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-25814/ (Markdown: https://insights.sbomify.com/CVE-2020-25814/index.md)","id":"CVE-2020-25814","markdown":"https://insights.sbomify.com/CVE-2020-25814/index.md","name":"CVE-2020-25814","record":{"aliases":["BIT-mediawiki-2020-25814","DEBIAN-CVE-2020-25814","GHSA-4vr7-m8p8-434h","UBUNTU-CVE-2020-25814"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki","requires_auth":"none","summary":"An attacker can inject malicious JavaScript via MediaWiki messages that executes when clicked, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an \u003ca\u003e tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an \u003ca href =\"javascript... that executes when clicked.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MediaWiki Cross-site Scripting (XSS) vulnerability","id":"CVE-2020-25814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","mediawiki:mediawiki"],"type":"xss","year":"2020"},"n_packages":7,"n_references":4,"next":{"headline":"MediaWiki Cross-site Scripting (XSS) vulnerability","id":"CVE-2020-25815"},"packages":[{"ecosystem":"Bitnami","fixed":["1.31.10","1.34.4"],"introduced":["0","1.32.0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2020-25814"},{"ecosystem":"Packagist","fixed":["1.31.9"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-4vr7-m8p8-434h"},{"ecosystem":"Packagist","fixed":["1.31.9"],"introduced":["1.31.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-4vr7-m8p8-434h"},{"ecosystem":"Packagist","fixed":["1.34.3"],"introduced":["1.32.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-4vr7-m8p8-434h"},{"ecosystem":"Packagist","fixed":["1.34.3"],"introduced":["1.32.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-4vr7-m8p8-434h"},{"ecosystem":"Packagist","fixed":["1.35.0"],"introduced":["1.35.0-rc.0"],"last_affected":[],"package":"mediawiki/core","purl":null,"source":"GHSA-4vr7-m8p8-434h"},{"ecosystem":"Packagist","fixed":["1.35.0"],"introduced":["1.35.0-rc.0"],"last_affected":[],"package":"mediawiki/core","purl":"pkg:composer/mediawiki/core","source":"GHSA-4vr7-m8p8-434h"}],"prev":{"headline":"MediaWiki Special:UserRights exposes the existence of hidden users","id":"CVE-2020-25813"},"products":["n/a"],"published":"2020-09-27","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can inject malicious JavaScript via MediaWiki messages that executes when clicked, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2020-25814/"}