# CVE-2020-25817: SilverStripe XXE Vulnerability in CSSContentParser

> Misuse of a developer utility for parsing user-submitted data allows XXE attacks, potentially leading to XSS or data exposure in SilverStripe applications.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-silverstripe-2020-25817, GHSA-3vjc-5x79-m9r8

## What is CVE-2020-25817?

CVE-2020-25817 is a medium-severity vulnerability in Silverstripe Silverstripe, published on 8 Jun 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

SilverStripe through 4.6.0-rc1 has an XXE Vulnerability in CSSContentParser. A developer utility meant for parsing HTML within unit tests can be vulnerable to XML External Entity (XXE) attacks. When this developer utility is misused for purposes involving external or user submitted data in custom project code, it can lead to vulnerabilities such as XSS on HTML output rendered through this custom code. This is now mitigated by disabling external entities during parsing. (The correct CVE ID year is 2020 [CVE-2020-25817, not CVE-2021-25817]).

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2020-25817?

3 open source packages ship an affected version, including silverstripe/framework and silverstripe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.7.4 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.7.4 |
| `silverstripe` | Bitnami | All versions to 4.6.0-rc1 | 4.6.0 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2020-25817?

Upgrade silverstripe/framework to 4.7.4 or later.

## Is CVE-2020-25817 being exploited?

There is no known exploitation of CVE-2020-25817 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25817 and fix it if it is affected.

What it is: CVE-2020-25817 is a medium-severity vulnerability in Silverstripe Silverstripe, published on 8 Jun 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-25817 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.7.4
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.7.4
- silverstripe (Bitnami): affected all versions up to 4.6.0-rc1; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25817/ (Markdown: https://insights.sbomify.com/CVE-2020-25817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25817
- OSV: https://osv.dev/vulnerability/CVE-2020-25817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25817/
Summaries are generated and may contain mistakes; the official description above is the record.
