CVE-2020-25827 OATHAuth extension in MediaWiki is not implementing rate limit
Attackers can bypass OATH token rate limits in clustered MediaWiki environments, enabling brute-force attacks against two-factor authentication.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-25827?
CVE-2020-25827 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 27 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the OATHAuth extension in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. For Wikis using OATHAuth on a farm/cluster (such as via CentralAuth), rate limiting of OATH tokens is only done on a single site level. Thus, multiple requests can be made across many wikis/sites concurrently.
Weakness: CWE-307
Which versions are affected by CVE-2020-25827?
5 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.31.0 | 1.31.9 |
mediawiki/core Packagist | From 1.31.0 | 1.31.9 |
mediawiki/core Packagist | From 1.32.0 | 1.34.3 |
mediawiki/core Packagist | From 1.32.0 | 1.34.3 |
mediawiki Bitnami | All versions | 1.31.10, 1.34.4 |
Products include Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2020-25827?
Upgrade mediawiki/core to a fixed version for your release line: 1.31.9 or 1.34.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-25827 being exploited?
There is no known exploitation of CVE-2020-25827 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-mediawiki-2020-25827, DEBIAN-CVE-2020-25827, GHSA-rqvj-fc2x-99q6, UBUNTU-CVE-2020-25827.