CVE-2020-25828 MediaWiki Cross-site Scripting (XSS) vulnerability
Cross-site scripting vulnerability in MediaWiki allows attackers to inject malicious scripts via unescaped HTML in message parameters when jqueryMsg is not loaded.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-25828?
CVE-2020-25828 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 27 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. The non-jqueryMsg version of mw.message().parse() doesn't escape HTML. This affects both message contents (which are generally safe) and the parameters (which can be based on user input). (When jqueryMsg is loaded, it correctly accepts only whitelisted tags in message contents, and escapes all parameters. Situations with an unloaded jqueryMsg are rare in practice, but can for example occur for Special:SpecialPages on a wiki with no extensions installed.)
Weakness: CWE-79
Which versions are affected by CVE-2020-25828?
7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | From 1.31.0 | 1.31.9 |
mediawiki/core Packagist | From 1.31.0 | 1.31.9 |
mediawiki/core Packagist | From 1.32.0 | 1.34.3 |
mediawiki/core Packagist | From 1.32.0 | 1.34.3 |
mediawiki/core Packagist | From 1.35.0-rc.0 | 1.35.0 |
mediawiki/core Packagist | From 1.35.0-rc.0 | 1.35.0 |
1 more packages
mediawiki Bitnami | From 1.31.10 | 1.31.11, 1.34.4 |
Products include Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2020-25828?
Upgrade mediawiki/core to a fixed version for your release line: 1.31.9, 1.34.3 or 1.35.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-25828 being exploited?
There is no known exploitation of CVE-2020-25828 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-mediawiki-2020-25828, DEBIAN-CVE-2020-25828, GHSA-h8qx-mj6v-2934, UBUNTU-CVE-2020-25828.