# CVE-2020-25864: HashiCorp Consul Cross-site Scripting vulnerability

> HashiCorp Consul's KV raw mode is vulnerable to cross-site scripting, allowing attackers to inject malicious scripts into the web UI.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Apr 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-consul-2020-25864, DEBIAN-CVE-2020-25864, GHSA-8xmx-h8rq-h94j, GO-2023-1851, UBUNTU-CVE-2020-25864

## What is CVE-2020-25864?

CVE-2020-25864 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HashiCorp Consul and Consul Enterprise up to version 1.9.4 key-value (KV) raw mode was vulnerable to cross-site scripting. Fixed in 1.9.5, 1.8.10 and 1.7.14.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-25864?

8 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | All versions | 1.7.14, 1.8.10, 1.9.5 |
| `github.com/hashicorp/consul` | Go | All versions | 1.7.14 |
| `github.com/hashicorp/consul` | Go | All versions | 1.7.14 |
| `github.com/hashicorp/consul` | Go | From 1.8.0 | 1.8.10 |
| `github.com/hashicorp/consul` | Go | From 1.8.0 | 1.8.10 |
| `github.com/hashicorp/consul` | Go | From 1.9.0 | 1.9.5 |
| `github.com/hashicorp/consul` | Go | From 1.9.0 | 1.9.5 |
| `consul` | Bitnami | All versions | 1.7.14, 1.8.10, 1.9.5 |

Products: Hashicorp Consul.

## How do I fix CVE-2020-25864?

Upgrade github.com/hashicorp/consul to a fixed version for your release line: 1.7.14, 1.8.10 or 1.9.5.

## Is CVE-2020-25864 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-25864 exists.

Public exploit code:

- HashiCorp Consul/Consul Enterprise <=1.9.4 - Cross-Site Scripting (nuclei): http/cves/2020/CVE-2020-25864.yaml

## Other vulnerabilities in n/a

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25864 and fix it if it is affected.

What it is: CVE-2020-25864 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-25864 exists.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.7.14, 1.8.10, 1.9.5
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.7.14
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.7.14
- github.com/hashicorp/consul (Go): affected from 1.8.0; fixed in 1.8.10
- github.com/hashicorp/consul (Go): affected from 1.8.0; fixed in 1.8.10
- github.com/hashicorp/consul (Go): affected from 1.9.0; fixed in 1.9.5
- github.com/hashicorp/consul (Go): affected from 1.9.0; fixed in 1.9.5
- consul (Bitnami): affected all versions; fixed in 1.7.14, 1.8.10, 1.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25864/ (Markdown: https://insights.sbomify.com/CVE-2020-25864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25864
- OSV: https://osv.dev/vulnerability/CVE-2020-25864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25864/
Summaries are generated and may contain mistakes; the official description above is the record.
