# CVE-2020-25915: ThinkCMF Cross-site Scripting Vulnerability

> Attackers can execute arbitrary code via crafted user_login in ThinkCMF due to a Cross Site Scripting vulnerability in UserController.php.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 9 Oct 2024
- **Also known as:** GHSA-4847-gqxx-v9xp

## What is CVE-2020-25915?

CVE-2020-25915 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-25915?

2 open source packages ship an affected version, including thinkcmf/thinkcmf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thinkcmf/thinkcmf` | Packagist | All versions | 5.1.7 |
| `thinkcmf/thinkcmf` | Packagist | All versions | 5.1.7 |

Products: Thinkcmf Thinkcmf.

## How do I fix CVE-2020-25915?

Upgrade thinkcmf/thinkcmf to 5.1.7 or later.

## Is CVE-2020-25915 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-25915 exists.

## Other vulnerabilities in n/a

- [CVE-2024-31615](https://insights.sbomify.com/CVE-2024-31615/): File upload in n/a (critical 9.8)
- [CVE-2020-20601](https://insights.sbomify.com/CVE-2020-20601/): Code injection in n/a (critical 9.8)
- [CVE-2019-6713](https://insights.sbomify.com/CVE-2019-6713/): Code injection in n/a (critical 9.8)
- [CVE-2022-40489](https://insights.sbomify.com/CVE-2022-40489/): ThinkCMF Cross Site Request Forgery (CSRF) vulnerability (high 8.8)
- [CVE-2019-7580](https://insights.sbomify.com/CVE-2019-7580/): Code injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-25915 and fix it if it is affected.

What it is: CVE-2020-25915 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Aug 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-25915 exists.

Affected packages and fixed versions:
- thinkcmf/thinkcmf (Packagist): affected all versions; fixed in 5.1.7
- thinkcmf/thinkcmf (Packagist): affected all versions; fixed in 5.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-25915/ (Markdown: https://insights.sbomify.com/CVE-2020-25915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-25915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-25915
- OSV: https://osv.dev/vulnerability/CVE-2020-25915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-25915/
Summaries are generated and may contain mistakes; the official description above is the record.
