# CVE-2020-26135: Cross-site scripting in n/a

> Attackers can execute arbitrary scripts in victim browsers via reflected XSS in Live Helper Chat, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-livehelperchat-2020-26135, GHSA-89jf-r8r5-xvvg

## What is CVE-2020-26135?

CVE-2020-26135 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Live Helper Chat before 3.44v allows reflected XSS via the setsettingajax PATH_INFO.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-26135?

1 open source package ship an affected version, including livehelperchat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `livehelperchat` | Bitnami | All versions | 3.44.0 |

Products: Livehelperchat Live Helper Chat.

## How do I fix CVE-2020-26135?

Upgrade livehelperchat to 3.44.0 or later.

## Is CVE-2020-26135 being exploited?

There is no known exploitation of CVE-2020-26135 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-27516](https://insights.sbomify.com/CVE-2024-27516/): livehelperchat Server-Side Template Injection (critical 9.8)
- [CVE-2022-0935](https://insights.sbomify.com/CVE-2022-0935/): Host Header injection in password Reset in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1234](https://insights.sbomify.com/CVE-2022-1234/): XSS in livehelperchat in livehelperchat/livehelperchat (high 8.8)
- [CVE-2022-1191](https://insights.sbomify.com/CVE-2022-1191/): SSRF on index.php/cobrowse/proxycss/ in livehelperchat/livehelperchat (high 8.7)
- [CVE-2022-1213](https://insights.sbomify.com/CVE-2022-1213/): SSRF filter bypass port 80, 433 in livehelperchat/livehelperchat (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26135 and fix it if it is affected.

What it is: CVE-2020-26135 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26135 in the wild and no public exploit code.

Affected packages and fixed versions:
- livehelperchat (Bitnami): affected all versions; fixed in 3.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26135/ (Markdown: https://insights.sbomify.com/CVE-2020-26135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26135
- OSV: https://osv.dev/vulnerability/CVE-2020-26135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26135/
Summaries are generated and may contain mistakes; the official description above is the record.
