# CVE-2020-26211: Cross-Site Scripting in BookStack

> An attacker with page edit permissions can inject JavaScript via javascript: URIs or meta tags, leading to script execution or silent redirects.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ch37-ch8w-cfrq, GHSA-r2cf-8778-3jgp

## What is CVE-2020-26211?

CVE-2020-26211 is a high-severity cross-site scripting vulnerability in BookStackApp BookStack, published on 3 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of `javascript:` URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround without upgrading, page edit permissions could be limited to only those that are trusted until you can upgrade although this will not address existing exploitation of this vulnerability. The issue is fixed in BookStack version 0.30.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-26211?

2 open source packages ship an affected version, including ssddanbrown/bookstack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ssddanbrown/bookstack` | Packagist | All versions | 0.30.4 |
| `ssddanbrown/bookstack` | Packagist | All versions | 0.30.4 |

Products: Bookstackapp Bookstack.

## How do I fix CVE-2020-26211?

Upgrade ssddanbrown/bookstack to 0.30.4 or later.

## Is CVE-2020-26211 being exploited?

There is no known exploitation of CVE-2020-26211 in the wild and no public exploit code.

## Other vulnerabilities in BookStackApp BookStack

- [CVE-2020-5256](https://insights.sbomify.com/CVE-2020-5256/): Remote Code Execution Through Image Uploads in BookStack (high 7.9)
- [CVE-2020-26210](https://insights.sbomify.com/CVE-2020-26210/): Cross-Site Scripting in BookStack (high 7.7)
- [CVE-2022-0877](https://insights.sbomify.com/CVE-2022-0877/): Cross-site Scripting (XSS) - Stored in bookstackapp/bookstack (high 7.6)
- [CVE-2021-3915](https://insights.sbomify.com/CVE-2021-3915/): Unrestricted Upload of File with Dangerous Type in bookstackapp/bookstack (high 7.6)
- [CVE-2023-6199](https://insights.sbomify.com/CVE-2023-6199/): Book Stack v23.10.2 - LFR via Blind SSRF (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26211 and fix it if it is affected.

What it is: CVE-2020-26211 is a high-severity cross-site scripting vulnerability in BookStackApp BookStack, published on 3 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26211 in the wild and no public exploit code.

Affected packages and fixed versions:
- ssddanbrown/bookstack (Packagist): affected all versions; fixed in 0.30.4
- ssddanbrown/bookstack (Packagist): affected all versions; fixed in 0.30.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26211/ (Markdown: https://insights.sbomify.com/CVE-2020-26211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26211
- OSV: https://osv.dev/vulnerability/CVE-2020-26211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26211/
Summaries are generated and may contain mistakes; the official description above is the record.
