# CVE-2020-26214: LDAP authentication bypass in Alerta

> Attackers can bypass LDAP authentication in Alerta by providing an empty password if the LDAP server allows anonymous binds.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5hmm-x8q8-w5jh, PYSEC-2020-159

## What is CVE-2020-26214?

CVE-2020-26214 is a critical authentication bypass vulnerability in alerta, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Alerta before version 8.1.0, users may be able to bypass LDAP authentication if they provide an empty password when Alerta server is configure to use LDAP as the authorization provider. Only deployments where LDAP servers are configured to allow unauthenticated authentication mechanism for anonymous authorization are affected. A fix has been implemented in version 8.1.0 that returns HTTP 401 Unauthorized response for any authentication attempts where the password field is empty. As a workaround LDAP administrators can disallow unauthenticated bind requests by clients.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2020-26214?

5 open source packages ship an affected version, including alerta-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alerta-server` | PyPI | All versions | 7.5.7, 8.1.0 |
| `alerta-server` | PyPI | All versions | 7.5.7 |
| `alerta-server` | PyPI | All versions | 7.5.7 |
| `alerta-server` | PyPI | From 8.0.0 | 8.1.0 |
| `alerta-server` | PyPI | From 8.0.0 | 8.1.0 |

Products: Alerta Project Alerta.

## How do I fix CVE-2020-26214?

Upgrade alerta-server to a fixed version for your release line: 7.5.7 or 8.1.0.

## Is CVE-2020-26214 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26214 exists.

Public exploit code:

- Alerta < 8.1.0 - Authentication Bypass (nuclei): http/cves/2020/CVE-2020-26214.yaml

## Other vulnerabilities in alerta

- [CVE-2026-34400](https://insights.sbomify.com/CVE-2026-34400/): alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26214 and fix it if it is affected.

What it is: CVE-2020-26214 is a critical authentication bypass vulnerability in alerta, published on 6 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26214 exists.

Affected packages and fixed versions:
- alerta-server (PyPI): affected all versions; fixed in 7.5.7, 8.1.0
- alerta-server (PyPI): affected all versions; fixed in 7.5.7
- alerta-server (PyPI): affected all versions; fixed in 7.5.7
- alerta-server (PyPI): affected from 8.0.0; fixed in 8.1.0
- alerta-server (PyPI): affected from 8.0.0; fixed in 8.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26214/ (Markdown: https://insights.sbomify.com/CVE-2020-26214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26214
- OSV: https://osv.dev/vulnerability/CVE-2020-26214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26214/
Summaries are generated and may contain mistakes; the official description above is the record.
