# CVE-2020-26215: Open redirect in Jupyter Notebook

> Attackers can craft links to redirect users from a Jupyter Notebook server to malicious external sites, potentially facilitating phishing attacks.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-jupyter-base-notebook-2020-26215, BIT-jupyter-notebook-2020-26215, DEBIAN-CVE-2020-26215, DLA-2477-1, GHSA-c7vm-f5p4-8fqh, MGASA-2020-0457, PYSEC-2020-215, UBUNTU-CVE-2020-26215, openSUSE-SU-2021:0024-1, openSUSE-SU-2021:0078-1, openSUSE-SU-2021:0117-1

## What is CVE-2020-26215?

CVE-2020-26215 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jupyter Notebook before version 6.1.5 has an Open redirect vulnerability. A maliciously crafted link to a notebook server could redirect the browser to a different website. All notebook servers are technically affected, however, these maliciously crafted links can only be reasonably made for known notebook server hosts. A link to your notebook server may appear safe, but ultimately redirect to a spoofed server on the public internet. The issue is patched in version 6.1.5.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2020-26215?

5 open source packages ship an affected version, including notebook, jupyter-base-notebook and jupyter-notebook. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `notebook` | PyPI | All versions | 6.1.5 |
| `notebook` | PyPI | All versions | 6.1.5 |
| `notebook` | PyPI | All versions | 6.1.5 |
| `jupyter-base-notebook` | Bitnami | All versions | 6.1.5 |
| `jupyter-notebook` | Bitnami | All versions | 6.1.5 |
| `python-jupyter_notebook` | SUSE:Package Hub 15 SP1 | All versions | 5.7.7-bp151.3.3.1 |
| `python-jupyter_notebook` | openSUSE:Leap 15.1 | All versions | 5.7.7-lp151.2.3.1 |
| `python-notebook` | openSUSE:Leap 15.2 | All versions | 5.7.8-lp152.2.3.1 |

Products: Debian Debian Linux, Jupyter Notebook.

## How do I fix CVE-2020-26215?

Upgrade notebook to 6.1.5 or later.

## Is CVE-2020-26215 being exploited?

There is no known exploitation of CVE-2020-26215 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26215 and fix it if it is affected.

What it is: CVE-2020-26215 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26215 in the wild and no public exploit code.

Affected packages and fixed versions:
- notebook (PyPI): affected all versions; fixed in 6.1.5
- notebook (PyPI): affected all versions; fixed in 6.1.5
- notebook (PyPI): affected all versions; fixed in 6.1.5
- jupyter-base-notebook (Bitnami): affected all versions; fixed in 6.1.5
- jupyter-notebook (Bitnami): affected all versions; fixed in 6.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26215/ (Markdown: https://insights.sbomify.com/CVE-2020-26215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26215
- OSV: https://osv.dev/vulnerability/CVE-2020-26215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26215/
Summaries are generated and may contain mistakes; the official description above is the record.
