CVE-2020-26216 Cross-Site Scripting in TYPO3 Fluid

High 8.0 Published Updated

Cross-site scripting vulnerabilities in TYPO3 Fluid allow attackers to inject malicious scripts via crafted attributes or unescaped content arguments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-26216?

CVE-2020-26216 is a high-severity cross-site scripting vulnerability in TYPO3 Fluid, published on 17 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

TYPO3 Fluid before versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 and 2.6.10 is vulnerable to Cross-Site Scripting. Three XSS vulnerabilities have been detected in Fluid: 1. TagBasedViewHelper allowed XSS through maliciously crafted additionalAttributes arrays by creating keys with attribute-closing quotes followed by HTML. When rendering such attributes, TagBuilder would not escape the keys. 2. ViewHelpers which used the CompileWithContentArgumentAndRenderStatic trait, and which declared escapeOutput = false, would receive the content argument in unescaped format. 3. Subclasses of AbstractConditionViewHelper would receive the then and else arguments in unescaped format. Update to versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 or 2.6.10 of this typo3fluid/fluid package that fix the problem described. More details are available in the linked advisory.

Weakness: CWE-79

Which versions are affected by CVE-2020-26216?

14 open source packages ship an affected version, including typo3fluid/fluid. It affects 1 product.

PackageAffectedFixed in
typo3fluid/fluid PackagistFrom 2.0.02.0.8
typo3fluid/fluid PackagistFrom 2.0.02.0.8
typo3fluid/fluid PackagistFrom 2.1.02.1.7
typo3fluid/fluid PackagistFrom 2.1.02.1.7
typo3fluid/fluid PackagistFrom 2.2.02.2.4
typo3fluid/fluid PackagistFrom 2.2.02.2.4
8 more packages
typo3fluid/fluid PackagistFrom 2.3.02.3.7
typo3fluid/fluid PackagistFrom 2.3.02.3.7
typo3fluid/fluid PackagistFrom 2.4.02.4.4
typo3fluid/fluid PackagistFrom 2.4.02.4.4
typo3fluid/fluid PackagistFrom 2.5.02.5.11
typo3fluid/fluid PackagistFrom 2.5.02.5.11
typo3fluid/fluid PackagistFrom 2.6.02.6.10
typo3fluid/fluid PackagistFrom 2.6.02.6.10

Products include Typo3 Fluid.

How do I fix CVE-2020-26216?

Upgrade typo3fluid/fluid to a fixed version for your release line: 2.0.8, 2.1.7, 2.2.4 or 2.3.7.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-26216 being exploited?

There is no known exploitation of CVE-2020-26216 in the wild and no public exploit code.

Sources

Also known as GHSA-hpjm-3ww5-6cpf.

Is CVE-2020-26216 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free