# CVE-2020-26216: Cross-Site Scripting in TYPO3 Fluid

> Cross-site scripting vulnerabilities in TYPO3 Fluid allow attackers to inject malicious scripts via crafted attributes or unescaped content arguments.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hpjm-3ww5-6cpf

## What is CVE-2020-26216?

CVE-2020-26216 is a high-severity cross-site scripting vulnerability in TYPO3 Fluid, published on 17 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TYPO3 Fluid before versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 and 2.6.10 is vulnerable to Cross-Site Scripting. Three XSS vulnerabilities have been detected in Fluid: 1. TagBasedViewHelper allowed XSS through maliciously crafted additionalAttributes arrays by creating keys with attribute-closing quotes followed by HTML. When rendering such attributes, TagBuilder would not escape the keys. 2. ViewHelpers which used the CompileWithContentArgumentAndRenderStatic trait, and which declared escapeOutput = false, would receive the content argument in unescaped format. 3. Subclasses of AbstractConditionViewHelper would receive the then and else arguments in unescaped format. Update to versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 or 2.6.10 of this typo3fluid/fluid package that fix the problem described. More details are available in the linked advisory.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-26216?

14 open source packages ship an affected version, including typo3fluid/fluid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3fluid/fluid` | Packagist | From 2.0.0 | 2.0.8 |
| `typo3fluid/fluid` | Packagist | From 2.0.0 | 2.0.8 |
| `typo3fluid/fluid` | Packagist | From 2.1.0 | 2.1.7 |
| `typo3fluid/fluid` | Packagist | From 2.1.0 | 2.1.7 |
| `typo3fluid/fluid` | Packagist | From 2.2.0 | 2.2.4 |
| `typo3fluid/fluid` | Packagist | From 2.2.0 | 2.2.4 |
| `typo3fluid/fluid` | Packagist | From 2.3.0 | 2.3.7 |
| `typo3fluid/fluid` | Packagist | From 2.3.0 | 2.3.7 |
| `typo3fluid/fluid` | Packagist | From 2.4.0 | 2.4.4 |
| `typo3fluid/fluid` | Packagist | From 2.4.0 | 2.4.4 |
| `typo3fluid/fluid` | Packagist | From 2.5.0 | 2.5.11 |
| `typo3fluid/fluid` | Packagist | From 2.5.0 | 2.5.11 |
| `typo3fluid/fluid` | Packagist | From 2.6.0 | 2.6.10 |
| `typo3fluid/fluid` | Packagist | From 2.6.0 | 2.6.10 |

Products: Typo3 Fluid.

## How do I fix CVE-2020-26216?

Upgrade typo3fluid/fluid to a fixed version for your release line: 2.0.8, 2.1.7, 2.2.4 or 2.3.7.

## Is CVE-2020-26216 being exploited?

There is no known exploitation of CVE-2020-26216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26216 and fix it if it is affected.

What it is: CVE-2020-26216 is a high-severity cross-site scripting vulnerability in TYPO3 Fluid, published on 17 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26216 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3fluid/fluid (Packagist): affected from 2.0.0; fixed in 2.0.8
- typo3fluid/fluid (Packagist): affected from 2.0.0; fixed in 2.0.8
- typo3fluid/fluid (Packagist): affected from 2.1.0; fixed in 2.1.7
- typo3fluid/fluid (Packagist): affected from 2.1.0; fixed in 2.1.7
- typo3fluid/fluid (Packagist): affected from 2.2.0; fixed in 2.2.4
- typo3fluid/fluid (Packagist): affected from 2.2.0; fixed in 2.2.4
- typo3fluid/fluid (Packagist): affected from 2.3.0; fixed in 2.3.7
- typo3fluid/fluid (Packagist): affected from 2.3.0; fixed in 2.3.7
- typo3fluid/fluid (Packagist): affected from 2.4.0; fixed in 2.4.4
- typo3fluid/fluid (Packagist): affected from 2.4.0; fixed in 2.4.4
- typo3fluid/fluid (Packagist): affected from 2.5.0; fixed in 2.5.11
- typo3fluid/fluid (Packagist): affected from 2.5.0; fixed in 2.5.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26216/ (Markdown: https://insights.sbomify.com/CVE-2020-26216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26216
- OSV: https://osv.dev/vulnerability/CVE-2020-26216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26216/
Summaries are generated and may contain mistakes; the official description above is the record.
