# CVE-2020-26217: Remote Code Execution in XStream

> Remote attackers can execute arbitrary shell commands via manipulated input streams in XStream if relying on blocklists instead of allowlists.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Nov 2020
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-activemq-2020-26217, DEBIAN-CVE-2020-26217, DLA-2471-1, DSA-4811-1, GHSA-mw36-7c6c-q4q2, RHSA-2021:0162, UBUNTU-CVE-2020-26217

## What is CVE-2020-26217?

CVE-2020-26217 is a high-severity command injection vulnerability in Apache Activemq, published on 16 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-26217?

3 open source packages ship an affected version, including activemq and com.thoughtworks.xstream:xstream. It affects 15 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions to 5.16.0 | 5.15.14 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.14-java7 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.14-java7 |
| `xstream` | Red Hat:enterprise_linux:7::client | All versions | 0:1.3.1-12.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::client | All versions | 0:1.3.1-12.el7_9 |
| `xstream` | Red Hat:enterprise_linux:7::computenode | All versions | 0:1.3.1-12.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::computenode | All versions | 0:1.3.1-12.el7_9 |
| `xstream` | Red Hat:enterprise_linux:7::server | All versions | 0:1.3.1-12.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::server | All versions | 0:1.3.1-12.el7_9 |
| `xstream` | Red Hat:enterprise_linux:7::workstation | All versions | 0:1.3.1-12.el7_9 |
| `xstream-javadoc` | Red Hat:enterprise_linux:7::workstation | All versions | 0:1.3.1-12.el7_9 |

Products: Apache Activemq, Debian Debian Linux, Netapp Snapmanager, Oracle Banking Cash Management, Oracle Banking Corporate Lending Process Management, Oracle Banking Credit Facilities Process Management, Oracle Banking Platform, Oracle Banking Supply Chain Finance, Oracle Banking Trade Finance Process Management, Oracle Banking Virtual Account Management, Oracle Business Activity Monitoring, Oracle Communications Policy Management, Oracle Endeca Information Discovery Studio, Oracle Retail Xstore Point of Service, Xstream Xstream.

## How do I fix CVE-2020-26217?

Upgrade activemq to 5.15.14 or later.

## Is CVE-2020-26217 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26217 exists.

Public exploit code:

- CVE-2020-26217 XStream RCE POC (github_poc): https://github.com/novysodope/CVE-2020-26217-XStream-RCE-POC
- CVE-2020-26217 && XStream RCE (github_poc): https://github.com/Al1ex/CVE-2020-26217
- CVE-2020-26217 XStream反序列化的poc (github_poc): https://github.com/Kairo-one/CVE-2020-26217-XStream
- xstream with CVE-2020-26217 (github_poc): https://github.com/epicosy/XStream-1
- https://github.com/cuijiung/xstream-CVE-2020-26217 (github_poc): https://github.com/cuijiung/xstream-CVE-2020-26217
- https://github.com/shoucheng3/x-stream__xstream_CVE-2020-26217_1-4-14-java77 (github_poc): https://github.com/shoucheng3/x-stream__xstream_CVE-2020-26217_1-4-14-java77

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26217 and fix it if it is affected.

What it is: CVE-2020-26217 is a high-severity command injection vulnerability in Apache Activemq, published on 16 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26217 exists.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions up to 5.16.0; fixed in 5.15.14
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.14-java7
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.14-java7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26217/ (Markdown: https://insights.sbomify.com/CVE-2020-26217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26217
- OSV: https://osv.dev/vulnerability/CVE-2020-26217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26217/
Summaries are generated and may contain mistakes; the official description above is the record.
