# CVE-2020-26218: HTML Injection in touchbase.ai

> An attacker can inject HTML payloads into touchbase.ai, potentially causing defacement or redirecting users to malicious sites.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 Nov 2020
- **Updated:** 4 Aug 2024

## What is CVE-2020-26218?

CVE-2020-26218 is a high-severity cross-site scripting vulnerability in puncsky touchbase.ai, published on 11 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

touchbase.ai before version 2.0 is vulnerable to Cross-Site Scripting. The vulnerability allows an attacker to inject HTML payloads which could result in defacement, user redirection to a malicious webpage/website etc. The issue is patched in version 2.0.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-26218?

It affects 1 product.


Products: Touchbase.ai Project Touchbase.ai.

## How do I fix CVE-2020-26218?

No fix has been published for CVE-2020-26218 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-26218 being exploited?

There is no known exploitation of CVE-2020-26218 in the wild and no public exploit code.

Public exploit code:

- Touchbase.io 1.10 - Stored Cross Site Scripting (exploitdb)

## Other vulnerabilities in puncsky touchbase.ai

- [CVE-2020-26221](https://insights.sbomify.com/CVE-2020-26221/): Stored Cross Site Scripting in touchbase.ai (high 8.0)
- [CVE-2020-26219](https://insights.sbomify.com/CVE-2020-26219/): Open Redirect in touchbase.ai (medium 4.7)
- [CVE-2020-26220](https://insights.sbomify.com/CVE-2020-26220/): Information exposure in touchbase.ai (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26218 and fix it if it is affected.

What it is: CVE-2020-26218 is a high-severity cross-site scripting vulnerability in puncsky touchbase.ai, published on 11 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26218 in the wild and no public exploit code.

Affected product: puncsky touchbase.ai. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26218/ (Markdown: https://insights.sbomify.com/CVE-2020-26218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26218
- OSV: https://osv.dev/vulnerability/CVE-2020-26218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26218/
Summaries are generated and may contain mistakes; the official description above is the record.
