{"answers":{"affected":"4 open source packages ship an affected version, including dependabot-common and dependabot-omnibus. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26222 in the wild and no public exploit code.","fix":"Upgrade dependabot-common to 0.125.1 or later.","what":"CVE-2020-26222 is a high-severity vulnerability in dependabot-core, published on 13 Nov 2020."},"fix_prompt":"Check this codebase for CVE-2020-26222 and fix it if it is affected.\n\nWhat it is: CVE-2020-26222 is a high-severity vulnerability in dependabot-core, published on 13 Nov 2020. \nExploitation: There is no known exploitation of CVE-2020-26222 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dependabot-common (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1\n- dependabot-common (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1\n- dependabot-omnibus (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1\n- dependabot-omnibus (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26222/ (Markdown: https://insights.sbomify.com/CVE-2020-26222/index.md)","id":"CVE-2020-26222","markdown":"https://insights.sbomify.com/CVE-2020-26222/index.md","name":"CVE-2020-26222","record":{"aliases":["GHSA-23f7-99jx-m54r"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"dependabot","vendor":"dependabot_project"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Dependabot is a set of packages for automated dependency management for Ruby, JavaScript, Python, PHP, Elixir, Rust, Java, .NET, Elm and Go. In Dependabot-Core from version 0.119.0.beta1 before version 0.125.1, there is a remote code execution vulnerability in dependabot-common and dependabot-go_modules when a source branch name contains malicious injectable bash code. For example, if Dependabot is configured to use the following source branch name: \"/$({curl,127.0.0.1})\", Dependabot will make a HTTP request to the following URL: 127.0.0.1 when cloning the source repository. The fix was applied to version 0.125.1. As a workaround, one can escape the branch name prior to passing it to the Dependabot::Source class.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote code execution in dependabot-core","id":"CVE-2020-26222","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2020"},"n_packages":4,"n_references":3,"next":{"headline":"Authorization bypass in Spree","id":"CVE-2020-26223"},"packages":[{"ecosystem":"RubyGems","fixed":["0.125.1"],"introduced":["0.119.0.beta1"],"last_affected":[],"package":"dependabot-common","purl":null,"source":"GHSA-23f7-99jx-m54r"},{"ecosystem":"RubyGems","fixed":["0.125.1"],"introduced":["0.119.0.beta1"],"last_affected":[],"package":"dependabot-common","purl":"pkg:gem/dependabot-common","source":"GHSA-23f7-99jx-m54r"},{"ecosystem":"RubyGems","fixed":["0.125.1"],"introduced":["0.119.0.beta1"],"last_affected":[],"package":"dependabot-omnibus","purl":null,"source":"GHSA-23f7-99jx-m54r"},{"ecosystem":"RubyGems","fixed":["0.125.1"],"introduced":["0.119.0.beta1"],"last_affected":[],"package":"dependabot-omnibus","purl":"pkg:gem/dependabot-omnibus","source":"GHSA-23f7-99jx-m54r"}],"prev":{"headline":"Stored Cross Site Scripting in touchbase.ai","id":"CVE-2020-26221"},"products":["dependabot-core"],"published":"2020-11-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["dependabot"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2020-26222/"}