# CVE-2020-26222: Remote code execution in dependabot-core


- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-23f7-99jx-m54r

## What is CVE-2020-26222?

CVE-2020-26222 is a high-severity vulnerability in dependabot-core, published on 13 Nov 2020. 

### Official description

Dependabot is a set of packages for automated dependency management for Ruby, JavaScript, Python, PHP, Elixir, Rust, Java, .NET, Elm and Go. In Dependabot-Core from version 0.119.0.beta1 before version 0.125.1, there is a remote code execution vulnerability in dependabot-common and dependabot-go_modules when a source branch name contains malicious injectable bash code. For example, if Dependabot is configured to use the following source branch name: "/$({curl,127.0.0.1})", Dependabot will make a HTTP request to the following URL: 127.0.0.1 when cloning the source repository. The fix was applied to version 0.125.1. As a workaround, one can escape the branch name prior to passing it to the Dependabot::Source class.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-26222?

4 open source packages ship an affected version, including dependabot-common and dependabot-omnibus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dependabot-common` | RubyGems | From 0.119.0.beta1 | 0.125.1 |
| `dependabot-common` | RubyGems | From 0.119.0.beta1 | 0.125.1 |
| `dependabot-omnibus` | RubyGems | From 0.119.0.beta1 | 0.125.1 |
| `dependabot-omnibus` | RubyGems | From 0.119.0.beta1 | 0.125.1 |

Products: Dependabot Project Dependabot.

## How do I fix CVE-2020-26222?

Upgrade dependabot-common to 0.125.1 or later.

## Is CVE-2020-26222 being exploited?

There is no known exploitation of CVE-2020-26222 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26222 and fix it if it is affected.

What it is: CVE-2020-26222 is a high-severity vulnerability in dependabot-core, published on 13 Nov 2020. 
Exploitation: There is no known exploitation of CVE-2020-26222 in the wild and no public exploit code.

Affected packages and fixed versions:
- dependabot-common (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1
- dependabot-common (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1
- dependabot-omnibus (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1
- dependabot-omnibus (RubyGems): affected from 0.119.0.beta1; fixed in 0.125.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26222/ (Markdown: https://insights.sbomify.com/CVE-2020-26222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26222
- OSV: https://osv.dev/vulnerability/CVE-2020-26222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26222/
Summaries are generated and may contain mistakes; the official description above is the record.
