CVE-2020-26223 Authorization bypass in Spree

High 7.7 Published Updated

Attackers can bypass authorization on the API v2 Order Status endpoint by using an empty token, potentially accessing order data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-26223?

CVE-2020-26223 is a high-severity authentication bypass vulnerability in spree, published on 13 Nov 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Spree is a complete open source e-commerce solution built with Ruby on Rails. In Spree from version 3.7 and before versions 3.7.13, 4.0.5, and 4.1.12, there is an authorization bypass vulnerability. The perpetrator could query the API v2 Order Status endpoint with an empty string passed as an Order token. This is patched in versions 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version. Users of Spree < 3.7 are not affected.

Weakness: CWE-863

Which versions are affected by CVE-2020-26223?

6 open source packages ship an affected version, including spree_api. It affects 1 product.

PackageAffectedFixed in
spree_api RubyGemsFrom 3.7.03.7.13
spree_api RubyGemsFrom 3.7.03.7.13
spree_api RubyGemsFrom 4.0.04.0.5
spree_api RubyGemsFrom 4.0.04.0.5
spree_api RubyGemsFrom 4.1.04.1.12
spree_api RubyGemsFrom 4.1.04.1.12

Products include Spreecommerce Spree.

How do I fix CVE-2020-26223?

Upgrade spree_api to a fixed version for your release line: 3.7.13, 4.0.5 or 4.1.12.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2020-26223 being exploited?

There is no known exploitation of CVE-2020-26223 in the wild and no public exploit code.

Sources

Also known as GHSA-m2jr-hmc3-qmpr.

Is CVE-2020-26223 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free