CVE-2020-26225 Reflected XSS in PrestaShop Product Comments

High 8.7 Published Updated

An attacker can inject malicious web code into users' browsers via a crafted link in the PrestaShop Product Comments plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-26225?

CVE-2020-26225 is a high-severity cross-site scripting vulnerability in PrestaShop productcomments, published on 16 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In PrestaShop Product Comments before version 4.2.0, an attacker could inject malicious web code into the users' web browsers by creating a malicious link. The problem was introduced in version 4.0.0 and is fixed in 4.2.0

Weakness: CWE-79

Which versions are affected by CVE-2020-26225?

2 open source packages ship an affected version, including prestashop/productcomments. It affects 1 product.

PackageAffectedFixed in
prestashop/productcomments PackagistFrom 4.0.04.2.0
prestashop/productcomments PackagistFrom 4.0.04.2.0

Products include Prestashop Product Comments.

How do I fix CVE-2020-26225?

Upgrade prestashop/productcomments to 4.2.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-26225 being exploited?

There is no known exploitation of CVE-2020-26225 in the wild and no public exploit code.

Sources

Also known as GHSA-58w4-w77w-qv3w.

Is CVE-2020-26225 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free