CVE-2020-26227 Cross-Site Scripting in Fluid view helpers
Attackers can execute arbitrary scripts in victim browsers via user-controlled data in TYPO3 Fluid view helpers, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-26227?
CVE-2020-26227 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 23 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 9.5.23 and 10.4.10 the system extension Fluid (typo3/cms-fluid) of the TYPO3 core is vulnerable to cross-site scripting passing user-controlled data as argument to Fluid view helpers. Update to TYPO3 versions 9.5.23 or 10.4.10 that fix the problem described.
Weakness: CWE-79
Which versions are affected by CVE-2020-26227?
13 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms Packagist | From 10.0.0 | 10.4.10 |
typo3/cms Packagist | From 10.0.0 | 10.4.10 |
typo3/cms Packagist | From 8.7.0 | 8.7.38 |
typo3/cms Packagist | From 8.7.0 | 8.7.38 |
typo3/cms Packagist | From 9.0.0 | 9.5.23 |
typo3/cms Packagist | From 9.0.0 | 9.5.23 |
7 more packages
typo3 Bitnami | From 6.2.0 | 6.2.54, 7.6.48, 8.7.38, 9.5.23, 10.4.10 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.10 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.10 |
typo3/cms-core Packagist | From 8.7.0 | 8.7.38 |
typo3/cms-core Packagist | From 8.7.0 | 8.7.38 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.23 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.23 |
Products include Typo3 Typo3.
How do I fix CVE-2020-26227?
Upgrade typo3/cms to a fixed version for your release line: 10.4.10, 8.7.38 or 9.5.23.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-26227 being exploited?
There is no known exploitation of CVE-2020-26227 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as BIT-typo3-2020-26227, GHSA-vqqx-jw6p-q3rf.