# CVE-2020-26227: Cross-Site Scripting in Fluid view helpers

> Attackers can execute arbitrary scripts in victim browsers via user-controlled data in TYPO3 Fluid view helpers, requiring an upgrade to patched versions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-typo3-2020-26227, GHSA-vqqx-jw6p-q3rf

## What is CVE-2020-26227?

CVE-2020-26227 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 23 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TYPO3 is an open source PHP based web content management system. In TYPO3 before versions 9.5.23 and 10.4.10 the system extension Fluid (typo3/cms-fluid) of the TYPO3 core is vulnerable to cross-site scripting passing user-controlled data as argument to Fluid view helpers. Update to TYPO3 versions 9.5.23 or 10.4.10 that fix the problem described.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-26227?

13 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.10 |
| `typo3/cms` | Packagist | From 10.0.0 | 10.4.10 |
| `typo3/cms` | Packagist | From 8.7.0 | 8.7.38 |
| `typo3/cms` | Packagist | From 8.7.0 | 8.7.38 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.23 |
| `typo3/cms` | Packagist | From 9.0.0 | 9.5.23 |
| `typo3` | Bitnami | From 6.2.0 | 6.2.54, 7.6.48, 8.7.38, 9.5.23, 10.4.10 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.10 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.10 |
| `typo3/cms-core` | Packagist | From 8.7.0 | 8.7.38 |
| `typo3/cms-core` | Packagist | From 8.7.0 | 8.7.38 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.23 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.23 |

Products: Typo3 Typo3.

## How do I fix CVE-2020-26227?

Upgrade typo3/cms to a fixed version for your release line: 10.4.10, 8.7.38 or 9.5.23.

## Is CVE-2020-26227 being exploited?

There is no known exploitation of CVE-2020-26227 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26227 and fix it if it is affected.

What it is: CVE-2020-26227 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 23 Nov 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26227 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.10
- typo3/cms (Packagist): affected from 10.0.0; fixed in 10.4.10
- typo3/cms (Packagist): affected from 8.7.0; fixed in 8.7.38
- typo3/cms (Packagist): affected from 8.7.0; fixed in 8.7.38
- typo3/cms (Packagist): affected from 9.0.0; fixed in 9.5.23
- typo3/cms (Packagist): affected from 9.0.0; fixed in 9.5.23
- typo3 (Bitnami): affected from 6.2.0; fixed in 6.2.54, 7.6.48, 8.7.38, 9.5.23, 10.4.10
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.10
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.10
- typo3/cms-core (Packagist): affected from 8.7.0; fixed in 8.7.38
- typo3/cms-core (Packagist): affected from 8.7.0; fixed in 8.7.38
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26227/ (Markdown: https://insights.sbomify.com/CVE-2020-26227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26227
- OSV: https://osv.dev/vulnerability/CVE-2020-26227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26227/
Summaries are generated and may contain mistakes; the official description above is the record.
