# CVE-2020-26231: Bypass of fix for CVE-2020-15247, Twig sandbox escape

> Authenticated users can bypass Twig sandbox restrictions to execute arbitrary PHP code if safe mode is enabled.

- **Severity:** Medium 5.2 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-r89v-cgv7-3jhx

## What is CVE-2020-26231?

CVE-2020-26231 is a medium-severity code injection vulnerability in Octobercms October, published on 23 Nov 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

October is a free, open-source, self-hosted CMS platform based on the Laravel PHP Framework. A bypass of CVE-2020-15247 (fixed in 1.0.469 and 1.1.0) was discovered that has the same impact as CVE-2020-15247. An authenticated backend user with the cms.manage_pages, cms.manage_layouts, or cms.manage_partials permissions who would normally not be permitted to provide PHP code to be executed by the CMS due to cms.enableSafeMode being enabled is able to write specific Twig code to escape the Twig sandbox and execute arbitrary PHP. This is not a problem for anyone that trusts their users with those permissions to normally write & manage PHP within the CMS by not having cms.enableSafeMode enabled, but would be a problem for anyone relying on cms.enableSafeMode to ensure that users with those permissions in production do not have access to write & execute arbitrary PHP. Issue has been patched in Build 470 (v1.0.470) and v1.1.1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2020-26231?

2 open source packages ship an affected version, including october/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/cms` | Packagist | From 1.0.469 | 1.0.470 |
| `october/cms` | Packagist | From 1.0.469 | 1.0.470 |

Products: Octobercms October.

## How do I fix CVE-2020-26231?

Upgrade october/cms to 1.0.470 or later.

## Is CVE-2020-26231 being exploited?

There is no known exploitation of CVE-2020-26231 in the wild and no public exploit code.

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26231 and fix it if it is affected.

What it is: CVE-2020-26231 is a medium-severity code injection vulnerability in Octobercms October, published on 23 Nov 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26231 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/cms (Packagist): affected from 1.0.469; fixed in 1.0.470
- october/cms (Packagist): affected from 1.0.469; fixed in 1.0.470

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26231/ (Markdown: https://insights.sbomify.com/CVE-2020-26231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26231
- OSV: https://osv.dev/vulnerability/CVE-2020-26231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26231/
Summaries are generated and may contain mistakes; the official description above is the record.
