# CVE-2020-26237: Prototype Pollution in highlight.js

> Prototype pollution in highlight.js allows attackers to cause denial of service via malicious HTML code blocks if user input is rendered.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLSA-2026-1788553382, DEBIAN-CVE-2020-26237, DLA-2511-1, GHSA-vfrc-7r7c-w9mx, UBUNTU-CVE-2020-26237, USN-8276-1

## What is CVE-2020-26237?

CVE-2020-26237 is a medium-severity vulnerability in Debian Debian Linux, published on 24 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Highlight.js is a syntax highlighter written in JavaScript. Highlight.js versions before 9.18.2 and 10.1.2 are vulnerable to Prototype Pollution. A malicious HTML code block can be crafted that will result in prototype pollution of the base object's prototype during highlighting. If you allow users to insert custom HTML code blocks into your page/app via parsing Markdown code blocks (or similar) and do not filter the language names the user can provide you may be vulnerable. The pollution should just be harmless data but this can cause problems for applications not expecting these properties to exist and can result in strange behavior or application crashes, i.e. a potential DOS vector. If your website or application does not render user provided data it should be unaffected. Versions 9.18.2 and 10.1.2 and newer include fixes for this vulnerability. If you are using version 7 or 8 you are encouraged to upgrade to a newer release.

Weakness: CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2020-26237?

4 open source packages ship an affected version, including highlight.js. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `highlight.js` | npm | All versions | 9.18.2 |
| `highlight.js` | npm | All versions | 9.18.2 |
| `highlight.js` | npm | From 10.0.0 | 10.1.2 |
| `highlight.js` | npm | From 10.0.0 | 10.1.2 |

Products: Debian Debian Linux, Highlightjs Highlight.js, Oracle Mysql Enterprise Monitor.

## How do I fix CVE-2020-26237?

Upgrade highlight.js to a fixed version for your release line: 9.18.2 or 10.1.2.

## Is CVE-2020-26237 being exploited?

There is no known exploitation of CVE-2020-26237 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26237 and fix it if it is affected.

What it is: CVE-2020-26237 is a medium-severity vulnerability in Debian Debian Linux, published on 24 Nov 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26237 in the wild and no public exploit code.

Affected packages and fixed versions:
- highlight.js (npm): affected all versions; fixed in 9.18.2
- highlight.js (npm): affected all versions; fixed in 9.18.2
- highlight.js (npm): affected from 10.0.0; fixed in 10.1.2
- highlight.js (npm): affected from 10.0.0; fixed in 10.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26237/ (Markdown: https://insights.sbomify.com/CVE-2020-26237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26237
- OSV: https://osv.dev/vulnerability/CVE-2020-26237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26237/
Summaries are generated and may contain mistakes; the official description above is the record.
