{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-26247 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.11.0 or later.","what":"CVE-2020-26247 is a low-severity vulnerability in Debian Debian Linux, published on 30 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-26247 and fix it if it is affected.\n\nWhat it is: CVE-2020-26247 is a low-severity vulnerability in Debian Debian Linux, published on 30 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-26247 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.11.0\n- nokogiri (RubyGems): affected all versions; fixed in 1.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26247/ (Markdown: https://insights.sbomify.com/CVE-2020-26247/index.md)","id":"CVE-2020-26247","markdown":"https://insights.sbomify.com/CVE-2020-26247/index.md","name":"CVE-2020-26247","record":{"aliases":["DEBIAN-CVE-2020-26247","DLA-2678-1","GHSA-vr8q-g5c7-m54m","OESA-2021-1144","UBUNTU-CVE-2020-26247"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML parser","requires_auth":"low_privilege","summary":"An XXE vulnerability in Nokogiri allows attackers to access external resources via trusted XML Schemas, potentially leading to data disclosure or SSRF.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"nokogiri","vendor":"nokogiri"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri before version 1.11.0.rc4 there is an XXE vulnerability. XML Schemas parsed by Nokogiri::XML::Schema are trusted by default, allowing external resources to be accessed over the network, potentially enabling XXE or SSRF attacks. This behavior is counter to the security policy followed by Nokogiri maintainers, which is to treat all input as untrusted by default whenever possible. This is fixed in Nokogiri version 1.11.0.rc4.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE in Nokogiri","id":"CVE-2020-26247","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"xxe","year":"2020"},"n_packages":2,"n_references":8,"next":{"headline":"Blind SQL injection during the CommentGrade process","id":"CVE-2020-26248"},"packages":[{"ecosystem":"RubyGems","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-vr8q-g5c7-m54m"},{"ecosystem":"RubyGems","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-vr8q-g5c7-m54m"}],"prev":{"headline":"Authorization bypass in Pimcore","id":"CVE-2020-26246"},"products":["nokogiri"],"published":"2020-12-30","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["sparklemotion"]},"summary":"An XXE vulnerability in Nokogiri allows attackers to access external resources via trusted XML Schemas, potentially leading to data disclosure or SSRF.","url":"https://insights.sbomify.com/CVE-2020-26247/"}