# CVE-2020-26247: XXE in Nokogiri

> An XXE vulnerability in Nokogiri allows attackers to access external resources via trusted XML Schemas, potentially leading to data disclosure or SSRF.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-26247, DLA-2678-1, GHSA-vr8q-g5c7-m54m, OESA-2021-1144, UBUNTU-CVE-2020-26247

## What is CVE-2020-26247?

CVE-2020-26247 is a low-severity vulnerability in Debian Debian Linux, published on 30 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri before version 1.11.0.rc4 there is an XXE vulnerability. XML Schemas parsed by Nokogiri::XML::Schema are trusted by default, allowing external resources to be accessed over the network, potentially enabling XXE or SSRF attacks. This behavior is counter to the security policy followed by Nokogiri maintainers, which is to treat all input as untrusted by default whenever possible. This is fixed in Nokogiri version 1.11.0.rc4.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2020-26247?

2 open source packages ship an affected version, including nokogiri. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.11.0 |
| `nokogiri` | RubyGems | All versions | 1.11.0 |

Products: Debian Debian Linux, Nokogiri Nokogiri.

## How do I fix CVE-2020-26247?

Upgrade nokogiri to 1.11.0 or later.

## Is CVE-2020-26247 being exploited?

There is no known exploitation of CVE-2020-26247 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26247 and fix it if it is affected.

What it is: CVE-2020-26247 is a low-severity vulnerability in Debian Debian Linux, published on 30 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26247 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.11.0
- nokogiri (RubyGems): affected all versions; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26247/ (Markdown: https://insights.sbomify.com/CVE-2020-26247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26247
- OSV: https://osv.dev/vulnerability/CVE-2020-26247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26247/
Summaries are generated and may contain mistakes; the official description above is the record.
