# CVE-2020-26248: Blind SQL injection during the CommentGrade process

> Attackers can exploit blind SQL injection in the PrestaShop productcomments module to retrieve data or crash the MySQL service.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5v44-7647-xfw9

## What is CVE-2020-26248?

CVE-2020-26248 is a medium-severity SQL injection vulnerability in PrestaShop productcomments, published on 3 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In the PrestaShop module "productcomments" before version 4.2.1, an attacker can use a Blind SQL injection to retrieve data or stop the MySQL service. The problem is fixed in 4.2.1 of the module.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-26248?

2 open source packages ship an affected version, including prestashop/productcomments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/productcomments` | Packagist | From 4.0.0 | 4.2.1 |
| `prestashop/productcomments` | Packagist | From 4.0.0 | 4.2.1 |

Products: Prestashop Productcomments.

## How do I fix CVE-2020-26248?

Upgrade prestashop/productcomments to 4.2.1 or later.

## Is CVE-2020-26248 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26248 exists.

Public exploit code:

- PrestaShop Product Comments <4.2.0 - SQL Injection (nuclei): http/cves/2020/CVE-2020-26248.yaml

## Other vulnerabilities in PrestaShop productcomments

- [CVE-2022-35933](https://insights.sbomify.com/CVE-2022-35933/): PrestaShop module Product Comments vulnerable to cross-site scripting (XSS) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26248 and fix it if it is affected.

What it is: CVE-2020-26248 is a medium-severity SQL injection vulnerability in PrestaShop productcomments, published on 3 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-26248 exists.

Affected packages and fixed versions:
- prestashop/productcomments (Packagist): affected from 4.0.0; fixed in 4.2.1
- prestashop/productcomments (Packagist): affected from 4.0.0; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26248/ (Markdown: https://insights.sbomify.com/CVE-2020-26248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26248
- OSV: https://osv.dev/vulnerability/CVE-2020-26248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26248/
Summaries are generated and may contain mistakes; the official description above is the record.
