{"answers":{"affected":"3 open source packages ship an affected version, including oauthenticator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26250 in the wild and no public exploit code.","fix":"Upgrade oauthenticator to 0.12.2 or later.","what":"CVE-2020-26250 is a medium-severity missing authorization vulnerability in jupyterhub oauthenticator, published on 1 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-26250 and fix it if it is affected.\n\nWhat it is: CVE-2020-26250 is a medium-severity missing authorization vulnerability in jupyterhub oauthenticator, published on 1 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-26250 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- oauthenticator (PyPI): affected from 0.12.0; fixed in 0.12.2\n- oauthenticator (PyPI): affected from 0.12.0; fixed in 0.12.2\n- oauthenticator (PyPI): affected from 0.12.0; fixed in 0.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26250/ (Markdown: https://insights.sbomify.com/CVE-2020-26250/index.md)","id":"CVE-2020-26250","markdown":"https://insights.sbomify.com/CVE-2020-26250/index.md","name":"CVE-2020-26250","record":{"aliases":["GHSA-384w-5v3f-q499","PYSEC-2020-68"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterHub OAuth plugin","requires_auth":"low_privilege","summary":"OAuthenticator ignores deprecated whitelist configurations, allowing all authenticated users access when no other restrictions are set.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"oauthenticator","vendor":"jupyter"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"OAuthenticator is an OAuth login mechanism for JupyterHub. In oauthenticator from version 0.12.0 and before 0.12.2, the deprecated (in jupyterhub 1.2) configuration `Authenticator.whitelist`, which should be transparently mapped to `Authenticator.allowed_users` with a warning, is instead ignored by OAuthenticator classes, resulting in the same behavior as if this configuration has not been set. If this is the only mechanism of authorization restriction (i.e. no group or team restrictions in configuration) then all authenticated users will be allowed. Provider-based restrictions, including deprecated values such as `GitHubOAuthenticator.org_whitelist` are **not** affected. All users of OAuthenticator 0.12.0 and 0.12.1 with JupyterHub 1.2 (JupyterHub Helm chart 0.10.0-0.10.5) who use the `admin.whitelist.users` configuration in the jupyterhub helm chart or the `c.Authenticator.whitelist` configuration directly. Users of other deprecated configuration, e.g. `c.GitHubOAuthenticator.team_whitelist` are **not** affected. If you see a log line like this and expect a specific list of allowed usernames: \"[I 2020-11-27 16:51:54.528 JupyterHub app:1717] Not using allowed_users. Any authenticated user will be allowed.\" you are likely affected. Updating oauthenticator to 0.12.2 is recommended. A workaround is to replace the deprecated `c.Authenticator.whitelist = ...` with `c.Authenticator.allowed_users = ...`. If any users have been authorized during this time who should not have been, they must be deleted via the API or admin interface, per the referenced documentation.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Base class whitelist configuration ignored in OAuthenticator","id":"CVE-2020-26250","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2020"},"n_packages":3,"n_references":4,"next":{"headline":"CORS configuration is possibly vulnerable","id":"CVE-2020-26251"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.2"],"introduced":["0.12.0"],"last_affected":[],"package":"oauthenticator","purl":null,"source":"GHSA-384w-5v3f-q499"},{"ecosystem":"PyPI","fixed":["0.12.2"],"introduced":["0.12.0"],"last_affected":[],"package":"oauthenticator","purl":"pkg:pypi/oauthenticator","source":"GHSA-384w-5v3f-q499"},{"ecosystem":"PyPI","fixed":["0.12.2"],"introduced":["0.12.0"],"last_affected":[],"package":"oauthenticator","purl":"pkg:pypi/oauthenticator","source":"PYSEC-2020-68"}],"prev":{"headline":"Remote Code Execution (RCE) Exploit on Cross Site Scripting (XSS) Vulnerability","id":"CVE-2020-26249"},"products":["oauthenticator"],"published":"2020-12-01","related":[{"cvss_score":8.8,"headline":"OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims","id":"CVE-2026-33175","kev_date_added":null,"published":"2026-04-03"},{"cvss_score":8.8,"headline":"JupyterHub OAuthenticator elevation of privilege","id":"CVE-2018-7206","kev_date_added":null,"published":"2018-02-18"},{"cvss_score":7.5,"headline":"GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace","id":"CVE-2024-29033","kev_date_added":null,"published":"2024-03-20"},{"cvss_score":4.2,"headline":"Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator in oauthenticator","id":"CVE-2022-31027","kev_date_added":null,"published":"2022-06-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["jupyterhub"]},"summary":"OAuthenticator ignores deprecated whitelist configurations, allowing all authenticated users access when no other restrictions are set.","url":"https://insights.sbomify.com/CVE-2020-26250/"}