# CVE-2020-26250: Base class whitelist configuration ignored in OAuthenticator

> OAuthenticator ignores deprecated whitelist configurations, allowing all authenticated users access when no other restrictions are set.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-384w-5v3f-q499, PYSEC-2020-68

## What is CVE-2020-26250?

CVE-2020-26250 is a medium-severity missing authorization vulnerability in jupyterhub oauthenticator, published on 1 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OAuthenticator is an OAuth login mechanism for JupyterHub. In oauthenticator from version 0.12.0 and before 0.12.2, the deprecated (in jupyterhub 1.2) configuration `Authenticator.whitelist`, which should be transparently mapped to `Authenticator.allowed_users` with a warning, is instead ignored by OAuthenticator classes, resulting in the same behavior as if this configuration has not been set. If this is the only mechanism of authorization restriction (i.e. no group or team restrictions in configuration) then all authenticated users will be allowed. Provider-based restrictions, including deprecated values such as `GitHubOAuthenticator.org_whitelist` are **not** affected. All users of OAuthenticator 0.12.0 and 0.12.1 with JupyterHub 1.2 (JupyterHub Helm chart 0.10.0-0.10.5) who use the `admin.whitelist.users` configuration in the jupyterhub helm chart or the `c.Authenticator.whitelist` configuration directly. Users of other deprecated configuration, e.g. `c.GitHubOAuthenticator.team_whitelist` are **not** affected. If you see a log line like this and expect a specific list of allowed usernames: "[I 2020-11-27 16:51:54.528 JupyterHub app:1717] Not using allowed_users. Any authenticated user will be allowed." you are likely affected. Updating oauthenticator to 0.12.2 is recommended. A workaround is to replace the deprecated `c.Authenticator.whitelist = ...` with `c.Authenticator.allowed_users = ...`. If any users have been authorized during this time who should not have been, they must be deleted via the API or admin interface, per the referenced documentation.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-26250?

3 open source packages ship an affected version, including oauthenticator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauthenticator` | PyPI | From 0.12.0 | 0.12.2 |
| `oauthenticator` | PyPI | From 0.12.0 | 0.12.2 |
| `oauthenticator` | PyPI | From 0.12.0 | 0.12.2 |

Products: Jupyter Oauthenticator.

## How do I fix CVE-2020-26250?

Upgrade oauthenticator to 0.12.2 or later.

## Is CVE-2020-26250 being exploited?

There is no known exploitation of CVE-2020-26250 in the wild and no public exploit code.

## Other vulnerabilities in jupyterhub oauthenticator

- [CVE-2026-33175](https://insights.sbomify.com/CVE-2026-33175/): OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims (high 8.8)
- [CVE-2018-7206](https://insights.sbomify.com/CVE-2018-7206/): JupyterHub OAuthenticator elevation of privilege (high 8.8)
- [CVE-2024-29033](https://insights.sbomify.com/CVE-2024-29033/): GoogleOAuthenticator.hosted_domain incorrectly verifies membership of an Google organization/workspace (high 7.5)
- [CVE-2022-31027](https://insights.sbomify.com/CVE-2022-31027/): Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator in oauthenticator (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26250 and fix it if it is affected.

What it is: CVE-2020-26250 is a medium-severity missing authorization vulnerability in jupyterhub oauthenticator, published on 1 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26250 in the wild and no public exploit code.

Affected packages and fixed versions:
- oauthenticator (PyPI): affected from 0.12.0; fixed in 0.12.2
- oauthenticator (PyPI): affected from 0.12.0; fixed in 0.12.2
- oauthenticator (PyPI): affected from 0.12.0; fixed in 0.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26250/ (Markdown: https://insights.sbomify.com/CVE-2020-26250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26250
- OSV: https://osv.dev/vulnerability/CVE-2020-26250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26250/
Summaries are generated and may contain mistakes; the official description above is the record.
