{"answers":{"affected":"4 open source packages ship an affected version, including getkirby/cms and getkirby/panel. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-26255 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to 3.4.5 or later.","what":"CVE-2020-26255 is a medium-severity vulnerability in getkirby kirby, published on 8 Dec 2020. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-26255 and fix it if it is affected.\n\nWhat it is: CVE-2020-26255 is a medium-severity vulnerability in getkirby kirby, published on 8 Dec 2020. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-26255 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected from 3.0.0; fixed in 3.4.5\n- getkirby/cms (Packagist): affected from 3.0.0; fixed in 3.4.5\n- getkirby/panel (Packagist): affected all versions; fixed in 2.5.14\n- getkirby/panel (Packagist): affected all versions; fixed in 2.5.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26255/ (Markdown: https://insights.sbomify.com/CVE-2020-26255/index.md)","id":"CVE-2020-26255","markdown":"https://insights.sbomify.com/CVE-2020-26255/index.md","name":"CVE-2020-26255","record":{"aliases":["GHSA-g3h8-cg9x-47qw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kirby CMS","requires_auth":"high_privilege","summary":"Authenticated editors can upload and execute PHP Phar files, leading to remote code execution on the server.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kirby","vendor":"getkirby"},{"product":"panel","vendor":"getkirby"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Kirby is a CMS. In Kirby CMS (getkirby/cms) before version 3.4.5, and Kirby Panel before version 2.5.14 , an editor with full access to the Kirby Panel can upload a PHP .phar file and execute it on the server. This vulnerability is critical if you might have potential attackers in your group of authenticated Panel users, as they can gain access to the server with such a Phar file. Visitors without Panel access *cannot* use this attack vector. The problem has been patched in Kirby 2.5.14 and Kirby 3.4.5. Please update to one of these or a later version to fix the vulnerability. Note: Kirby 2 reaches end of life on December 31, 2020. We therefore recommend to upgrade your Kirby 2 sites to Kirby 3. If you cannot upgrade, we still recommend to update to Kirby 2.5.14.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PHP Phar archives could be uploaded and executed in Kirby","id":"CVE-2020-26255","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2020"},"n_packages":4,"n_references":6,"next":{"headline":"Denial of service in fast-csv","id":"CVE-2020-26256"},"packages":[{"ecosystem":"Packagist","fixed":["3.4.5"],"introduced":["3.0.0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-g3h8-cg9x-47qw"},{"ecosystem":"Packagist","fixed":["3.4.5"],"introduced":["3.0.0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-g3h8-cg9x-47qw"},{"ecosystem":"Packagist","fixed":["2.5.14"],"introduced":["0"],"last_affected":[],"package":"getkirby/panel","purl":null,"source":"GHSA-g3h8-cg9x-47qw"},{"ecosystem":"Packagist","fixed":["2.5.14"],"introduced":["0"],"last_affected":[],"package":"getkirby/panel","purl":"pkg:composer/getkirby/panel","source":"GHSA-g3h8-cg9x-47qw"}],"prev":{"headline":"omniauth-apple allows attacker to fake their email address during authentication","id":"CVE-2020-26254"},"products":["kirby"],"published":"2020-12-08","related":[{"cvss_score":8.8,"headline":"Kirby vulnerable to unrestricted file upload of user avatar images","id":"CVE-2024-26483","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":8.1,"headline":"Insufficient permission checks in the language settings in Kirby CMS","id":"CVE-2024-41964","kev_date_added":null,"published":"2024-08-29"},{"cvss_score":7.6,"headline":"Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering","id":"CVE-2026-34587","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.6,"headline":"Cross-site scripting (XSS) from unsanitized uploaded SVG files","id":"CVE-2021-29460","kev_date_added":null,"published":"2021-04-27"},{"cvss_score":7.3,"headline":"Kirby vulnerable to Insufficient Session Expiration after a password change","id":"CVE-2023-38489","kev_date_added":null,"published":"2023-07-27"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from writer field content in the site frontend","id":"CVE-2021-41252","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from image block content in the site frontend","id":"CVE-2021-41258","kev_date_added":null,"published":"2021-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["getkirby"]},"summary":"Authenticated editors can upload and execute PHP Phar files, leading to remote code execution on the server.","url":"https://insights.sbomify.com/CVE-2020-26255/"}