# CVE-2020-26255: PHP Phar archives could be uploaded and executed in Kirby

> Authenticated editors can upload and execute PHP Phar files, leading to remote code execution on the server.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g3h8-cg9x-47qw

## What is CVE-2020-26255?

CVE-2020-26255 is a medium-severity vulnerability in getkirby kirby, published on 8 Dec 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kirby is a CMS. In Kirby CMS (getkirby/cms) before version 3.4.5, and Kirby Panel before version 2.5.14 , an editor with full access to the Kirby Panel can upload a PHP .phar file and execute it on the server. This vulnerability is critical if you might have potential attackers in your group of authenticated Panel users, as they can gain access to the server with such a Phar file. Visitors without Panel access *cannot* use this attack vector. The problem has been patched in Kirby 2.5.14 and Kirby 3.4.5. Please update to one of these or a later version to fix the vulnerability. Note: Kirby 2 reaches end of life on December 31, 2020. We therefore recommend to upgrade your Kirby 2 sites to Kirby 3. If you cannot upgrade, we still recommend to update to Kirby 2.5.14.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2020-26255?

4 open source packages ship an affected version, including getkirby/cms and getkirby/panel. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | From 3.0.0 | 3.4.5 |
| `getkirby/cms` | Packagist | From 3.0.0 | 3.4.5 |
| `getkirby/panel` | Packagist | All versions | 2.5.14 |
| `getkirby/panel` | Packagist | All versions | 2.5.14 |

Products: Getkirby Kirby, Getkirby Panel.

## How do I fix CVE-2020-26255?

Upgrade getkirby/cms to 3.4.5 or later.

## Is CVE-2020-26255 being exploited?

There is no known exploitation of CVE-2020-26255 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26255 and fix it if it is affected.

What it is: CVE-2020-26255 is a medium-severity vulnerability in getkirby kirby, published on 8 Dec 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26255 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected from 3.0.0; fixed in 3.4.5
- getkirby/cms (Packagist): affected from 3.0.0; fixed in 3.4.5
- getkirby/panel (Packagist): affected all versions; fixed in 2.5.14
- getkirby/panel (Packagist): affected all versions; fixed in 2.5.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26255/ (Markdown: https://insights.sbomify.com/CVE-2020-26255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26255
- OSV: https://osv.dev/vulnerability/CVE-2020-26255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26255/
Summaries are generated and may contain mistakes; the official description above is the record.
