{"answers":{"affected":"4 open source packages ship an affected version, including @fast-csv/parse and fast-csv. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26256 in the wild and no public exploit code.","fix":"Upgrade @fast-csv/parse to 4.3.6 or later.","what":"CVE-2020-26256 is a medium-severity denial of service vulnerability in C2FO fast-csv, published on 8 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-26256 and fix it if it is affected.\n\nWhat it is: CVE-2020-26256 is a medium-severity denial of service vulnerability in C2FO fast-csv, published on 8 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-26256 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @fast-csv/parse (npm): affected all versions; fixed in 4.3.6\n- @fast-csv/parse (npm): affected all versions; fixed in 4.3.6\n- fast-csv (npm): affected all versions; fixed in 4.3.6\n- fast-csv (npm): affected all versions; fixed in 4.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26256/ (Markdown: https://insights.sbomify.com/CVE-2020-26256/index.md)","id":"CVE-2020-26256","markdown":"https://insights.sbomify.com/CVE-2020-26256/index.md","name":"CVE-2020-26256","record":{"aliases":["GHSA-8cv5-p934-3hwp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js CSV library","requires_auth":"low_privilege","summary":"Attackers can cause denial of service in fast-csv by exploiting a ReDoS vulnerability when the ignoreEmpty option is enabled.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fast-csv","vendor":"c2fo"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Fast-csv is an npm package for parsing and formatting CSVs or any other delimited value file in node. In fast-cvs before version 4.3.6 there is a possible ReDoS vulnerability (Regular Expression Denial of Service) when using ignoreEmpty option when parsing. This has been patched in `v4.3.6` You will only be affected by this if you use the `ignoreEmpty` parsing option. If you do use this option it is recommended that you upgrade to the latest version `v4.3.6` This vulnerability was found using a CodeQL query which identified `EMPTY_ROW_REGEXP` regular expression as vulnerable.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in fast-csv","id":"CVE-2020-26256","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":4,"n_references":6,"next":{"headline":"Denial of service attack via incorrect parameters to federation APIs","id":"CVE-2020-26257"},"packages":[{"ecosystem":"npm","fixed":["4.3.6"],"introduced":["0"],"last_affected":[],"package":"@fast-csv/parse","purl":null,"source":"GHSA-8cv5-p934-3hwp"},{"ecosystem":"npm","fixed":["4.3.6"],"introduced":["0"],"last_affected":[],"package":"@fast-csv/parse","purl":"pkg:npm/%40fast-csv/parse","source":"GHSA-8cv5-p934-3hwp"},{"ecosystem":"npm","fixed":["4.3.6"],"introduced":["0"],"last_affected":[],"package":"fast-csv","purl":null,"source":"GHSA-8cv5-p934-3hwp"},{"ecosystem":"npm","fixed":["4.3.6"],"introduced":["0"],"last_affected":[],"package":"fast-csv","purl":"pkg:npm/fast-csv","source":"GHSA-8cv5-p934-3hwp"}],"prev":{"headline":"PHP Phar archives could be uploaded and executed in Kirby","id":"CVE-2020-26255"},"products":["fast-csv"],"published":"2020-12-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["C2FO"]},"summary":"Attackers can cause denial of service in fast-csv by exploiting a ReDoS vulnerability when the ignoreEmpty option is enabled.","url":"https://insights.sbomify.com/CVE-2020-26256/"}