# CVE-2020-26257: Denial of service attack via incorrect parameters to federation APIs

> A malicious homeserver can cause denial of service in Matrix Synapse by injecting malformed events via federation APIs, affecting all servers accepting untrusted federation requests.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hxmp-pqch-c8mm, PYSEC-2020-236, UBUNTU-CVE-2020-26257

## What is CVE-2020-26257?

CVE-2020-26257 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 9 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Matrix is an ecosystem for open federated Instant Messaging and VoIP. Synapse is a reference "homeserver" implementation of Matrix. A malicious or poorly-implemented homeserver can inject malformed events into a room by specifying a different room id in the path of a `/send_join`, `/send_leave`, `/invite` or `/exchange_third_party_invite` request. This can lead to a denial of service in which future events will not be correctly sent to other servers over federation. This affects any server which accepts federation requests from untrusted servers. The Matrix Synapse reference implementation before version 1.23.1 the implementation is vulnerable to this injection attack. Issue is fixed in version 1.23.1. As a workaround homeserver administrators could limit access to the federation API to trusted servers (for example via `federation_domain_whitelist`).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-26257?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.23.1 |
| `matrix-synapse` | PyPI | All versions | 1.23.1 |
| `matrix-synapse` | PyPI | All versions | 1.23.1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2020-26257?

Upgrade matrix-synapse to 1.23.1 or later.

## Is CVE-2020-26257 being exploited?

There is no known exploitation of CVE-2020-26257 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26257 and fix it if it is affected.

What it is: CVE-2020-26257 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 9 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26257 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.23.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.23.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.23.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26257/ (Markdown: https://insights.sbomify.com/CVE-2020-26257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26257
- OSV: https://osv.dev/vulnerability/CVE-2020-26257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26257/
Summaries are generated and may contain mistakes; the official description above is the record.
