# CVE-2020-26272: Electron vulnerable to ID collision when routing IPC messages to renderers containing OOPIFs

> Electron IPC messages may be delivered to the wrong frame, allowing attackers to read or modify data in unintended contexts.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2021
- **Updated:** 27 May 2025
- **Also known as:** GHSA-hvf8-h2qh-37m9

## What is CVE-2020-26272?

CVE-2020-26272 is a medium-severity vulnerability in Electronjs Electron, published on 28 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Electron framework lets users write cross-platform desktop applications using JavaScript, HTML and CSS. In versions of Electron IPC prior to 9.4.0, 10.2.0, 11.1.0, and 12.0.0-beta.9, messages sent from the main process to a subframe in the renderer process, through webContents.sendToFrame, event.reply or when using the remote module, can in some cases be delivered to the wrong frame. If your app uses remote, calls webContents.sendToFrame, or calls event.reply in an IPC message handler then it is impacted by this issue. This has been fixed in versions 9.4.0, 10.2.0, 11.1.0, and 12.0.0-beta.9. There are no known workarounds for this issue.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2020-26272?

6 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 9.4.0 |
| `electron` | npm | All versions | 9.4.0 |
| `electron` | npm | From 10.0.0 | 10.2.0 |
| `electron` | npm | From 10.0.0 | 10.2.0 |
| `electron` | npm | From 11.0.0 | 11.1.0 |
| `electron` | npm | From 11.0.0 | 11.1.0 |

Products: Electronjs Electron.

## How do I fix CVE-2020-26272?

Upgrade electron to a fixed version for your release line: 9.4.0, 10.2.0 or 11.1.0.

## Is CVE-2020-26272 being exploited?

There is no known exploitation of CVE-2020-26272 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26272 and fix it if it is affected.

What it is: CVE-2020-26272 is a medium-severity vulnerability in Electronjs Electron, published on 28 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26272 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 9.4.0
- electron (npm): affected all versions; fixed in 9.4.0
- electron (npm): affected from 10.0.0; fixed in 10.2.0
- electron (npm): affected from 10.0.0; fixed in 10.2.0
- electron (npm): affected from 11.0.0; fixed in 11.1.0
- electron (npm): affected from 11.0.0; fixed in 11.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26272/ (Markdown: https://insights.sbomify.com/CVE-2020-26272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26272
- OSV: https://osv.dev/vulnerability/CVE-2020-26272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26272/
Summaries are generated and may contain mistakes; the official description above is the record.
