# CVE-2020-26275: Open redirect vulnerability

> Attackers can craft links that appear safe but redirect users to malicious sites, affecting Jupyter Server instances without a base URL prefix.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-26275, GHSA-9f66-54xg-pc2c, PYSEC-2020-50, UBUNTU-CVE-2020-26275

## What is CVE-2020-26275?

CVE-2020-26275 is a medium-severity vulnerability in jupyter-server jupyter_server, published on 21 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications like Jupyter notebook, JupyterLab, and Voila. In Jupyter Server before version 1.1.1, an open redirect vulnerability could cause the jupyter server to redirect the browser to a different malicious website. All jupyter servers running without a base_url prefix are technically affected, however, these maliciously crafted links can only be reasonably made for known jupyter server hosts. A link to your jupyter server may *appear* safe, but ultimately redirect to a spoofed server on the public internet. This same vulnerability was patched in upstream notebook v5.7.8. This is fixed in jupyter_server 1.1.1. If upgrade is not available, a workaround can be to run your server on a url prefix: "jupyter server --ServerApp.base_url=/jupyter/".

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2020-26275?

3 open source packages ship an affected version, including jupyter-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | All versions | 1.1.1 |
| `jupyter-server` | PyPI | All versions | 1.1.1 |
| `jupyter-server` | PyPI | All versions | 1.1.1 |

Products: Jupyter Jupyter Server.

## How do I fix CVE-2020-26275?

Upgrade jupyter-server to 1.1.1 or later.

## Is CVE-2020-26275 being exploited?

There is no known exploitation of CVE-2020-26275 in the wild and no public exploit code.

## Other vulnerabilities in jupyter-server jupyter_server

- [CVE-2026-44727](https://insights.sbomify.com/CVE-2026-44727/): Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP (critical 9.3)
- [CVE-2026-35397](https://insights.sbomify.com/CVE-2026-35397/): jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix (high 7.6)
- [CVE-2026-40110](https://insights.sbomify.com/CVE-2026-40110/): jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat (high 7.6)
- [CVE-2026-40934](https://insights.sbomify.com/CVE-2026-40934/): jupyter-server authentication cookies remain valid after password reset due to static cookie secret (high 7.6)
- [CVE-2024-35178](https://insights.sbomify.com/CVE-2024-35178/): Jupyter server on Windows discloses Windows user password hash (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26275 and fix it if it is affected.

What it is: CVE-2020-26275 is a medium-severity vulnerability in jupyter-server jupyter_server, published on 21 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26275 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected all versions; fixed in 1.1.1
- jupyter-server (PyPI): affected all versions; fixed in 1.1.1
- jupyter-server (PyPI): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26275/ (Markdown: https://insights.sbomify.com/CVE-2020-26275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26275
- OSV: https://osv.dev/vulnerability/CVE-2020-26275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26275/
Summaries are generated and may contain mistakes; the official description above is the record.
