{"answers":{"affected":"3 open source packages ship an affected version, including github.com/datacharmer/dbdeployer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26277 in the wild and no public exploit code.","fix":"Upgrade github.com/datacharmer/dbdeployer to 1.58.2 or later.","what":"CVE-2020-26277 is a medium-severity path traversal vulnerability in datacharmer dbdeployer, published on 21 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-26277 and fix it if it is affected.\n\nWhat it is: CVE-2020-26277 is a medium-severity path traversal vulnerability in datacharmer dbdeployer, published on 21 Dec 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-26277 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/datacharmer/dbdeployer (Go): affected all versions; fixed in 1.58.2\n- github.com/datacharmer/dbdeployer (Go): affected all versions; fixed in 1.58.2\n- github.com/datacharmer/dbdeployer (Go): affected all versions; fixed in 1.58.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26277/ (Markdown: https://insights.sbomify.com/CVE-2020-26277/index.md)","id":"CVE-2020-26277","markdown":"https://insights.sbomify.com/CVE-2020-26277/index.md","name":"CVE-2020-26277","record":{"aliases":["GHSA-47wr-426j-fr82","GO-2022-0787"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"MySQL deployment tool","requires_auth":"none","summary":"Attackers can overwrite system files via malicious tarballs if users run the tool as root and skip checksum verification, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dbdeployer","vendor":"dbdeployer"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"DBdeployer is a tool that deploys MySQL database servers easily. In DBdeployer before version 1.58.2, users unpacking a tarball may use a maliciously packaged tarball that contains symlinks to files external to the target. In such scenario, an attacker could induce dbdeployer to write into a system file, thus altering the computer defenses. For the attack to succeed, the following factors need to contribute: 1) The user is logged in as root. While dbdeployer is usable as root, it was designed to run as unprivileged user. 2) The user has taken a tarball from a non secure source, without testing the checksum. When the tarball is retrieved through dbdeployer, the checksum is compared before attempting to unpack. This has been fixed in version 1.58.2.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary read/write in DBdeployer","id":"CVE-2020-26277","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":3,"n_references":2,"next":{"headline":"Weave Net Pods running in host PID namespace can be used to escalate other Kubernetes vulnerabilities","id":"CVE-2020-26278"},"packages":[{"ecosystem":"Go","fixed":["1.58.2"],"introduced":["0"],"last_affected":[],"package":"github.com/datacharmer/dbdeployer","purl":null,"source":"GHSA-47wr-426j-fr82"},{"ecosystem":"Go","fixed":["1.58.2"],"introduced":["0"],"last_affected":[],"package":"github.com/datacharmer/dbdeployer","purl":"pkg:golang/github.com/datacharmer/dbdeployer","source":"GHSA-47wr-426j-fr82"},{"ecosystem":"Go","fixed":["1.58.2"],"introduced":["0"],"last_affected":[],"package":"github.com/datacharmer/dbdeployer","purl":"pkg:golang/github.com/datacharmer/dbdeployer","source":"GO-2022-0787"}],"prev":{"headline":"SAML authentication vulnerability in Fleet","id":"CVE-2020-26276"},"products":["dbdeployer"],"published":"2020-12-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["datacharmer"]},"summary":"Attackers can overwrite system files via malicious tarballs if users run the tool as root and skip checksum verification, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2020-26277/"}