{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26278 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-26278 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-26278 is a medium-severity vulnerability in weaveworks weave, published on 20 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-26278 and fix it if it is affected.\n\nWhat it is: CVE-2020-26278 is a medium-severity vulnerability in weaveworks weave, published on 20 Jan 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-26278 in the wild and no public exploit code.\n\nAffected product: weaveworks weave. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26278/ (Markdown: https://insights.sbomify.com/CVE-2020-26278/index.md)","id":"CVE-2020-26278","markdown":"https://insights.sbomify.com/CVE-2020-26278/index.md","name":"CVE-2020-26278","record":{"aliases":["GHSA-pg3p-v8c6-c6h3"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Kubernetes network plugin","requires_auth":"low_privilege","summary":"Attackers with code execution in Weave Net pods can escalate privileges to the host due to unnecessary hostPID access, requiring a secondary vulnerability to exploit.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"weave","vendor":"weave"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-250","name":"Execution with Unnecessary Privileges"}],"description":"Weave Net is open source software which creates a virtual network that connects Docker containers across multiple hosts and enables their automatic discovery. Weave Net before version 2.8.0 has a vulnerability in which can allow an attacker to take over any host in the cluster. Weave Net is supplied with a manifest that runs pods on every node in a Kubernetes cluster, which are responsible for managing network connections for all other pods in the cluster. This requires a lot of power over the host, and the manifest sets `privileged: true`, which gives it that power. It also set `hostPID: true`, which gave it the ability to access all other processes on the host, and write anywhere in the root filesystem of the host. This setting was not necessary, and is being removed. You are only vulnerable if you have an additional vulnerability (e.g. a bug in Kubernetes) or misconfiguration that allows an attacker to run code inside the Weave Net pod, No such bug is known at the time of release, and there are no known instances of this being exploited. Weave Net 2.8.0 removes the hostPID setting and moves CNI plugin install to an init container. Users who do not update to 2.8.0 can edit the hostPID line in their existing DaemonSet manifest to say false instead of true, arrange some other way to install CNI plugins (e.g. Ansible) and remove those mounts from the DaemonSet manifest.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Weave Net Pods running in host PID namespace can be used to escalate other Kubernetes vulnerabilities","id":"CVE-2020-26278","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2020"},"n_packages":0,"n_references":4,"next":{"headline":"Path traversal","id":"CVE-2020-26279"},"packages":[],"prev":{"headline":"Arbitrary read/write in DBdeployer","id":"CVE-2020-26277"},"products":["weave"],"published":"2021-01-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["weaveworks"]},"summary":"Attackers with code execution in Weave Net pods can escalate privileges to the host due to unnecessary hostPID access, requiring a secondary vulnerability to exploit.","url":"https://insights.sbomify.com/CVE-2020-26278/"}