CVE-2020-26280 XSS in OpenSlides
Attackers can inject persistent JavaScript into rich text fields to hijack sessions or manipulate votes in OpenSlides assemblies.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-26280?
CVE-2020-26280 is a high-severity cross-site scripting vulnerability in OpenSlides, published on 18 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
OpenSlides is a free, Web-based presentation and assembly system for managing and projecting agenda, motions, and elections of assemblies. OpenSlides version 3.2, due to unsufficient user input validation and escaping, it is vulnerable to persistant cross-site scripting (XSS). In the web applications users can enter rich text in various places, e.g. for personal notes or in motions. These fields can be used to store arbitrary JavaScript Code that will be executed when other users read the respective text. An attacker could utilize this vulnerability be used to manipulate votes of other users, hijack the moderators session or simply disturb the meeting. The vulnerability was introduced with 6eae497abeab234418dfbd9d299e831eff86ed45 on 16.04.2020, which is first included in the 3.2 release. It has been patched in version 3.3 ( in commit f3809fc8a97ee305d721662a75f788f9e9d21938, merged in master on 20.11.2020).
Weakness: CWE-79
Which versions are affected by CVE-2020-26280?
1 open source package ship an affected version, including openslides. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openslides PyPI | All versions | 3.3 |
Products include Openslides Openslides.
How do I fix CVE-2020-26280?
Upgrade openslides to 3.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-26280 being exploited?
There is no known exploitation of CVE-2020-26280 in the wild and no public exploit code.
Other vulnerabilities in OpenSlides
Sources
Also known as GHSA-w5wr-98qm-jx92, PYSEC-2020-72.