{"answers":{"affected":"1 open source package ship an affected version, including openslides. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-26280 in the wild and no public exploit code.","fix":"Upgrade openslides to 3.3 or later.","what":"CVE-2020-26280 is a high-severity cross-site scripting vulnerability in OpenSlides, published on 18 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-26280 and fix it if it is affected.\n\nWhat it is: CVE-2020-26280 is a high-severity cross-site scripting vulnerability in OpenSlides, published on 18 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-26280 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openslides (PyPI): affected all versions; fixed in 3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-26280/ (Markdown: https://insights.sbomify.com/CVE-2020-26280/index.md)","id":"CVE-2020-26280","markdown":"https://insights.sbomify.com/CVE-2020-26280/index.md","name":"CVE-2020-26280","record":{"aliases":["GHSA-w5wr-98qm-jx92","PYSEC-2020-72"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenSlides assembly system","requires_auth":"low_privilege","summary":"Attackers can inject persistent JavaScript into rich text fields to hijack sessions or manipulate votes in OpenSlides assemblies.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openslides","vendor":"openslides"}],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"OpenSlides is a free, Web-based presentation and assembly system for managing and projecting agenda, motions, and elections of assemblies. OpenSlides version 3.2, due to unsufficient user input validation and escaping, it is vulnerable to persistant cross-site scripting (XSS). In the web applications users can enter rich text in various places, e.g. for personal notes or in motions. These fields can be used to store arbitrary JavaScript Code that will be executed when other users read the respective text. An attacker could utilize this vulnerability be used to manipulate votes of other users, hijack the moderators session or simply disturb the meeting. The vulnerability was introduced with 6eae497abeab234418dfbd9d299e831eff86ed45 on 16.04.2020, which is first included in the 3.2 release. It has been patched in version 3.3 ( in commit f3809fc8a97ee305d721662a75f788f9e9d21938, merged in master on 20.11.2020).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS in OpenSlides","id":"CVE-2020-26280","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":1,"n_references":5,"next":{"headline":"request smuggling in async-h1","id":"CVE-2020-26281"},"packages":[{"ecosystem":"PyPI","fixed":["3.3"],"introduced":["0"],"last_affected":[],"package":"openslides","purl":"pkg:pypi/openslides","source":"PYSEC-2020-72"}],"prev":{"headline":"Path traversal","id":"CVE-2020-26279"},"products":["OpenSlides"],"published":"2020-12-18","related":[{"cvss_score":8.1,"headline":"OpenSlides has incorrect access control vulnerability in authentication service","id":"CVE-2026-25519","kev_date_added":null,"published":"2026-02-04"},{"cvss_score":7.5,"headline":"Weak cryptography in n/a","id":"CVE-2024-22892","kev_date_added":null,"published":"2024-09-25"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2024-22893","kev_date_added":null,"published":"2024-09-25"},{"cvss_score":5.4,"headline":"Cross-site scripting in OpenSlides","id":"CVE-2025-30342","kev_date_added":null,"published":"2025-03-21"},{"cvss_score":5.3,"headline":"Information disclosure in OpenSlides","id":"CVE-2025-30344","kev_date_added":null,"published":"2025-03-21"},{"cvss_score":3.5,"headline":"Cross-site scripting in OpenSlides","id":"CVE-2025-30345","kev_date_added":null,"published":"2025-03-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["OpenSlides"]},"summary":"Attackers can inject persistent JavaScript into rich text fields to hijack sessions or manipulate votes in OpenSlides assemblies.","url":"https://insights.sbomify.com/CVE-2020-26280/"}