# CVE-2020-26280: XSS in OpenSlides

> Attackers can inject persistent JavaScript into rich text fields to hijack sessions or manipulate votes in OpenSlides assemblies.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w5wr-98qm-jx92, PYSEC-2020-72

## What is CVE-2020-26280?

CVE-2020-26280 is a high-severity cross-site scripting vulnerability in OpenSlides, published on 18 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenSlides is a free, Web-based presentation and assembly system for managing and projecting agenda, motions, and elections of assemblies. OpenSlides version 3.2, due to unsufficient user input validation and escaping, it is vulnerable to persistant cross-site scripting (XSS). In the web applications users can enter rich text in various places, e.g. for personal notes or in motions. These fields can be used to store arbitrary JavaScript Code that will be executed when other users read the respective text. An attacker could utilize this vulnerability be used to manipulate votes of other users, hijack the moderators session or simply disturb the meeting. The vulnerability was introduced with 6eae497abeab234418dfbd9d299e831eff86ed45 on 16.04.2020, which is first included in the 3.2 release. It has been patched in version 3.3 ( in commit f3809fc8a97ee305d721662a75f788f9e9d21938, merged in master on 20.11.2020).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-26280?

1 open source package ship an affected version, including openslides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openslides` | PyPI | All versions | 3.3 |

Products: Openslides Openslides.

## How do I fix CVE-2020-26280?

Upgrade openslides to 3.3 or later.

## Is CVE-2020-26280 being exploited?

There is no known exploitation of CVE-2020-26280 in the wild and no public exploit code.

## Other vulnerabilities in OpenSlides

- [CVE-2026-25519](https://insights.sbomify.com/CVE-2026-25519/): OpenSlides has incorrect access control vulnerability in authentication service (high 8.1)
- [CVE-2024-22892](https://insights.sbomify.com/CVE-2024-22892/): Weak cryptography in n/a (high 7.5)
- [CVE-2024-22893](https://insights.sbomify.com/CVE-2024-22893/): Information disclosure in n/a (high 7.5)
- [CVE-2025-30342](https://insights.sbomify.com/CVE-2025-30342/): Cross-site scripting in OpenSlides (medium 5.4)
- [CVE-2025-30344](https://insights.sbomify.com/CVE-2025-30344/): Information disclosure in OpenSlides (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26280 and fix it if it is affected.

What it is: CVE-2020-26280 is a high-severity cross-site scripting vulnerability in OpenSlides, published on 18 Dec 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-26280 in the wild and no public exploit code.

Affected packages and fixed versions:
- openslides (PyPI): affected all versions; fixed in 3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26280/ (Markdown: https://insights.sbomify.com/CVE-2020-26280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26280
- OSV: https://osv.dev/vulnerability/CVE-2020-26280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26280/
Summaries are generated and may contain mistakes; the official description above is the record.
