# CVE-2020-26282: Template Injection in BrowserUp Proxy

> Unauthenticated attackers can achieve remote code execution by injecting Java EL expressions into BrowserUp Proxy.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wmfg-55f9-j8hq

## What is CVE-2020-26282?

CVE-2020-26282 is a critical code injection vulnerability in browserup-proxy, published on 24 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BrowserUp Proxy allows you to manipulate HTTP requests and responses, capture HTTP content, and export performance data as a HAR file. BrowserUp Proxy works well as a standalone proxy server, but it is especially useful when embedded in Selenium tests. A Server-Side Template Injection was identified in BrowserUp Proxy enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. This has been patched in version 2.1.2.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-26282?

2 open source packages ship an affected version, including com.browserup:browserup-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.browserup:browserup-proxy` | Maven | All versions | 2.1.2 |
| `com.browserup:browserup-proxy` | Maven | All versions | 2.1.2 |

Products: Browserup Browserup Proxy.

## How do I fix CVE-2020-26282?

Upgrade com.browserup:browserup-proxy to 2.1.2 or later.

## Is CVE-2020-26282 being exploited?

There is no known exploitation of CVE-2020-26282 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26282 and fix it if it is affected.

What it is: CVE-2020-26282 is a critical code injection vulnerability in browserup-proxy, published on 24 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26282 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.browserup:browserup-proxy (Maven): affected all versions; fixed in 2.1.2
- com.browserup:browserup-proxy (Maven): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26282/ (Markdown: https://insights.sbomify.com/CVE-2020-26282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26282
- OSV: https://osv.dev/vulnerability/CVE-2020-26282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26282/
Summaries are generated and may contain mistakes; the official description above is the record.
