# CVE-2020-26289: Regular expression Denial of Service in date-and-time

> Attackers can cause a denial of service in the date-and-time npm library by exploiting a regular expression parsing vulnerability.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLSA-2026-1792596188, GHSA-r92x-f52r-x54g

## What is CVE-2020-26289?

CVE-2020-26289 is a high-severity denial of service vulnerability in knowledgecode date-and-time, published on 28 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

date-and-time is an npm package for manipulating date and time. In date-and-time before version 0.14.2, there a regular expression involved in parsing which can be exploited to to cause a denial of service. This is fixed in version 0.14.2.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-26289?

2 open source packages ship an affected version, including date-and-time. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `date-and-time` | npm | All versions | 0.14.2 |
| `date-and-time` | npm | All versions | 0.14.2 |

Products: Date-and-Time Project Date-and-Time.

## How do I fix CVE-2020-26289?

Upgrade date-and-time to 0.14.2 or later.

## Is CVE-2020-26289 being exploited?

There is no known exploitation of CVE-2020-26289 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-26289 and fix it if it is affected.

What it is: CVE-2020-26289 is a high-severity denial of service vulnerability in knowledgecode date-and-time, published on 28 Dec 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-26289 in the wild and no public exploit code.

Affected packages and fixed versions:
- date-and-time (npm): affected all versions; fixed in 0.14.2
- date-and-time (npm): affected all versions; fixed in 0.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-26289/ (Markdown: https://insights.sbomify.com/CVE-2020-26289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-26289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-26289
- OSV: https://osv.dev/vulnerability/CVE-2020-26289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-26289/
Summaries are generated and may contain mistakes; the official description above is the record.
